Can't get my Republic Wireless icon to appear

What phone do you have? Moto g Stulus

What plan are you on? monthly 1 GB

Does your plan include data, or just talk & text? Data and Talk & Test


Issue Description

I suddenly can’t get my Republic Wireless half circle icon to appear. It seems to be on Wifi, but the convenient icon is missing from the top of my screen. Android version 11.
I already restarted the phone and I uninstalled the most recent [today’s] phone update from Google. Problem did not occur until today’s updates.
The icon is sometimes missing and sometimes only an outline, but when checking my RW app it shows that I am “On WiFi.”

Hi @terris.2eie6v,

Could you please check on the notification permissions?

  1. Open the Settings app
  2. Tap Apps & notifications
  3. Tap Republic Wireless (you may have to first tap to see all your apps)
  4. Tap Notifications
  5. Make sure the Republic Wireless Service Notifications toggle is blue and to the right.

If you had to enable the Service Notifications, then you can reboot the phone or simply turn WiFi off and back on to see if the arc appears.

Using the instructions provided by @southpaw, some of us still find that the icon doesn’t show … a simple off/on cycle of the Republic Wireless will restore it. This can also be done from the Republic Wireless App / Advanced Settings / Notifications (toggle Show the Notifications off then on)

Thanks, @jben, that’s true. After enabling the notification, you’d have to trigger a state change before actually seeing the notification again. Turning WiFi off and back on or rebooting the phone would make it appear.

I’ll add that step above.

1 Like

TY for the suggestion. The setting was already set as “Republic Wireless Service Notifications toggle is blue and to the right.” I toggled it off, then back on. Several minutes later the icon appeared and so far is holding the icon as expected. TY again.

1 Like

Because my notifications were all set to on when I followed southpaw’s instructions I toggled off "the Republic Wireless Service Notifications setting:", then toggled it back on. Kind of the same fix you describe here. So far it has held.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer