Can't make calls when connected to public WiFi that requires a login

What phone do you have? Samsung S9+, Android 9.0

What plan are you on? My Choice + 1 Gb

Does your plan include data, or just talk & text? Includes data


Issue Description

I find I’m unable to make voice calls whenever I happen to be in range of a public (unsecured) WiFi access point that requires a login, such as a hotel, restaurant, or Boingo. I don’t want to or cannot obtain the credentials required to login to the unsecured WiFi. I just want to make a voice call.

When the call fails to go through, I’ve learned to check Settings > Connections > WiFi and typically find that I’m connected to a public WAP. Turning off WiFi in the phone’s Settings temporarily “solves” the problem by routing the call over the cellular network, but it’s a hassle to go through this exercise each time this situation occurs. I thenhave to remember to turn WiFi back on when back in the presence of a secured WiFi whose credentials I’ve saved so I don’t burn through cell data unnecessarily. The nuisance factor is a serious drawback of RW’s service and is the primary issue that prevents me from recommending RW to others.

It seems to me the RW App (version 3.25.2.1) should be smart enough to know that if it cannot reach Republic’s servers over the current WiFi connection (for whatever reason), it should automatically route the voice call over the cellular network, just as it would if there were no WiFi connection at all. Having to turn off the WiFi radio to force this behavior is the definition of “user unfriendly.”

Do you ever connect to these networks? If not you can “forget” those networks in your WiFi settings and you won’t automatically connect to them again.

1 Like

jco42- These are random encounters with public WiFi Access Points that then require a login, typically while travelling. Forgetting such networks is NOT a viable solution. Having to manually forget every such random network that the phone happens to connect to is even more of a hassle than turning off the WiFi radio and redialing the failed call.

My point is this issue is something that the RW app should handle automatically without requiring any user intervention. If it can’t connect to the RW servers over WiFi for any reason, it should route the call over the cellular network.

Additionally, please don’t mark your response as “Solving” my problem. That’s for the original poster to determine.

1 Like

Hi @ericf.p52ay1,

The only people who can mark a topic solved are the original poster, staff, and our Insiders. @jco42 did not mark his own answer correct. I marked this one because typically “forgetting” a network to which you’ve connected previously keeps you from connecting again. You can unmark it, if it doesn’t solve the issue you’ve described.

There are two factors here: How Android works and how Republic works.
An Android phone typically does not auto-connect to any Wi-Fi network to which it has never connected before. If you’re seeing other behavior, we need to look into why that is.

Then there’s the separate factor of how Republic performs on those networks. What does the Republic Notification in say in these environments?

1 Like

Do you have this (open network notification) option in your WiFi settings? I turned this off so I don’t connect to public hotspots.

I hear you. I agree with you about the app being aware enough to know the difference. I’ve had this same issue as you. I’ve had success with the setting I described or forgetting the network. In my travels the ones I’ve come across tend to have the same name so after a little "forgetting I’ve been able to not have the issue anymore except at places where I actually connect to the wi-fi and then have to sign in. I would hope the engineers at RW are looking at this but who knows when they will implement such a feature? I’m offering you what has worked for me in the interim.

but my mom says i’m smart??? :grinning:

First, I apologize to jco42 for erroneously assuming you had marked your answer as Solving my issue. Southpaw took responsibiliy for that action, but there was no way I could determine that.

When I make a phone call that does not go through, I usually find that the phone is connected to an open Wi-Fi network to which it has never connected before (e.g., a restaurant I’ve never visited before). Turning off Wi-Fi then allows me to successfully place the same call again over RW’s GSM cellular network.

I checked my Wi-Fi Advanced options and found that both Network notification and Hotspot 2.0 (Automatically connect to Wi-Fi access points that support Hotspot 2.0) were turned On. I have now manually turned both of these settings Off. I’ll see if this resolves the problem the next time I find myself in the vicinity of a strong public Wi-Fi access point and no secured WAP to which I’ve previously connected.

Nevertheless, I still contend that being connected to a Wi-Fi access point is not sufficient justification for the RW app to route calls over Wi-Fi. If it cannot connect to RW’s servers for any reason (firewall issues, routing issues, internet not available, etc.), the call will not go through over Wi-Fi, and it should be routed automatically over the cellular network without requiring user intervention. This is not all that dissimilar to automatically switching to cell when the Wi-Fi signal is poor or lost, but in this case it’s not a poor Wi-Fi signal but the internet connection that’s the problem.

No worries, all in good fun…if you think about it how funny would that be if i could just roam message boards marking my drivel as the solution to people’s problems.

As a user I agree that this does not make sense. As a network engineer turned project manager I can say there is more behind the scenes that what you would think to make this work.

Again, as a user I see your point. I also agree that the wi-fi/mobile handover could be better and would be improved with your suggestion. Signal strength and what you can connect to are two different things. It’s more than “oh, look we didn’t think to check that we can connect to RW servers before deciding to use cell or wi-fi.”

Hopefully your suggestion will be added to the backlog and implemented sooner rather than later. In the meantime I’m sharing some tips i’ve learned along the way that help. I always pause when making a call if i’m walking out the door because if the call hasn’t connected then the handoff from wi-fi to mobile will just drop it. Paying $25/mo for a phone is going to be different experience than $100+/mo for a phone.

My primary reason for selecting and staying with RW is awful cell coverage (all 4 MNOs) at my home location (max 1 bar in one corner of the house). Having a cable Wi-Fi access point in the house allows my mobile phone to be a reliable communications tool at home. RW’s pricing is certainly an attractive feature as well.

The RW App clearly knows whether it can place Wi-Fi calls. It’s second tab (the Republic symbol) indicates whether it’s on Wi-Fi (“Connected to WiFi”), or has “Cell Calls and Text, Data only on Wi-Fi” on networks with bandwidth or port restrictions. In the latter case, it knows to route calls over the cellular network. I don’t see why Wi-Fi networks that restrict internet access prior to validating logon shouldn’t be handled the same way (“Cell calls and Text, no Data on Wi-Fi”).

As an Enterprise software architect & developer myself, I do appreciate the complexity that goes on “behind the curtain.” My design philosphy has always been for developers to go the extra mile to make the end-user experience as simple and intuitive as possible.

You mention being a former network engineer. Are you perhaps a RW employee?

Ha, no. I wish. Seems like a cool company.

Yes agree. I’m only saying I don’t think we can say they’re not doing that without seeing their backlog.

I could be totally wrong here. Maybe this is something they’ve overlooked and potentially don’t care about. I don’t think that’s the case. I’ve only had tangential experience with mobile networks. For as dark an art as WiFi is, dealing with mobile networks is a level up from the challenges with WiFi. I’m only assuming that competing a call takes more than a ping to RW servers. To your point it seems like a friction point worth investigating and solving.

I agree with all your points.

I’m certainly not suggesting that completing a call is as simply as pinging the RW servers. However, if the RW app CAN’T ping the RW servers, for certain it won’t be able to complete a call over WiFi, and therefore shouldn’t try. That’s the difference between necessity and sufficiency.

1 Like

Hi @ericf.p52ay1,

I discussed this scenario with our engineers, and they indicate the behavior you describe above is how the app is programmed to behave. If you are connected to a captive portal but have not signed in, calls will be routed over cell.

I took my phone to a location with a captive portal and tested, and found I was able to make calls over cell while in this “semi-connected” state.

The question then would be why you’re not seeing the same behavior. It’s also very curious that you’re auto-connecting to networks your phone has never before met.

Have you seen any improvement since making that change?

I also found something interesting on my phone and wondering if perhaps it is enabled on yours?
Settings > Network and internet > Wi-Fi > Wi-Fi Preferences > Auto-connect to Xfinity WiFi

1 Like

To add my experience to the mix, with my Pixel 3 and other wifi…

My phone auto connects to Xfinity Wifi all the time…as it is a saved network that I used all day at my previous work place. Also, many such of those exist all around my apartment complex to varying degrees of signal strength. When you first connect to Xfinity WiFi, you must use your Xfinity Internet accounts username and password to login and gain internet access. This seems to stick on the phone, installs a cookie or certificate, i am not sure, but my phone then will work on ANY Xfinity wifi it connects to anywhere, with no need to log in.

I can walk the halls of my complex, connecting and then dropping each Xfinity wifi and call will not drop, it hands over to cell and wifi just fine.

I have encountered a few wifi hotspots like in malls or restaurants in malls, that just wont work, cant get a captive portal, or any thing to work. Only once did it seem to make a call not work, soon as I turned off wifi, everything worked fine again on cell. May have been a routing issue/fault on that particular network. Or it was overloaded. With out seeing some network level analytics, like AP to client retry rate, dropped packet rates, latency counters, gateway and DNS responses…impossible to tell really the issue, just that i know it was not the phone.

2 Likes

SpeedingCheetah-

Your experience with Xfinitiy WiFi isn’t relevant to the problem I described precisely because you’ve saved your login credentials on the phone, so you automatically login and obtain internet access from Xfinity.

However, if you WERE NOT an Xfinity customer, your phone would still automatically connect to unsecured Xfinitiy hotspots but wouldn’t obtain internet access. That’s when the problem occurs. Because you’d have a good Wifi signal, the Republic App would try to route outgoing phone calls over the Xfinity WiFi connection, which naturally fails because Xfinity blocks internet access to RW’s servers.

In this situation, the App should be smart enough to automatically route outgoing calls over the cellular network. It should not require manual user intervention to turn off the WiFi radio, then redial the call in order to use the cellular network.

Note that incoming calls do not suffer the same fate because RW’s servers don’t see the phone as being active on the internet so quite properly route the incoming call over the cellular network.

Did you read @southpaw post above?

2 Likes

If you don’t want your phone to auto connect to a Xfinity wifi hotspot, simply “Forget” the network in your phones settings. Also, I believe you had mentioned that you u had the setting enabled to auto connect to open networks. Disable that. I see you have a Samsung phone, they may some other Samsung software that is auto connecting you to wifi hot spots that u do not want …

I was merely pointing out the fact that you can use Xifinty hotspots with no issue or captive portal once you login once, if you are a customer of theirs, if you are not, then you would have no need or desire to connect to their wifi in the first place. I have tested being logged out of Xfinity and having the captive portal but no internet acces, and calls text work fine over cell when still connected to the not open wifi.

Also, as I mentioned, the rare networks I had issues with, it was the network, not the phone.
Put I have a Pixel phone, not a Samsung, so there could be other factors in play software wise.

This situation doesn’t arise very often in my home area (NYC tri-state metro area) because I’m an Optimum (Cablevision) internet subscriber and they have over 2 million hotspots to which my phone automatically logs in.

I notice this behavior mostly when travelling, typically in hotels, restaurants, and some airports that have public WiFi and captive portals. Next time this happens I’ll try to diagnose the factors.

I seem to recall that the RW App version 2 used to automatically display the captive portal’s web page when you connected to an open WiFi with a captive portal. I always found that feature very useful because it let you know that authentication was required to reach the internet. I wonder why it was removed from version 3.

It was removed because it was made a standard feature of Android.

1 Like
Message an
Expert customer