Can't send messages with pictures on Samsung S10

Why suddenly I cannot send any text message with picture attached

  • Some things that would help folks provide a better answer (and hopefully fix the problem)
    • Which phone?
    • Does it fail on Cell as well as WiFi?
    • Do you have available cellular data?
1 Like

Phone Sumsung S10. Pictures do not go whether on cell or WIFI. Have available cellular data.

  • Has this ever worked?
  • Which Messaging App are you using?
1 Like

Google app. Always worked up to last Sunday.

Are you taking the picture using the camera icon in the messaging app or are you trying to send a picture you have already taken?

Tried both. Yesterday changed app, still same issue. Can’t sent message with picture attached.

  • When you say ‘Yesterday changed app’ what did you change it from/to?
    • Perhaps you are using the old Google app, make sure you’re are at the latest level … Google Messages
    • and make sure you have turned off ‘Chat features’ in the App settings

I was changes between Google messenger and Sumsung messenger. No effect.
I can still receive message from others with picture but cannot send one. Also receiving some strange message from “republic wireless” with link rpb.lc/download. I think it is spam.

Thanks for the additional details.

Please be sure you are using one of the two supported apps:

Messages by Google

Republic Anywhere

Please try Google Messages not messenger. Samsung messenger is not up to the latest requirements either and will not work.

  • Here is a possible reference to the ‘strange message’ you received (it also validates the address you questioned: To Access This Message Please Install and Open the Republic Wireless App – Republic Help
    • I would also suggest making sure that you have ‘mobile data’ turned on in your Galaxy Android Settings (use the spyglass search within Settings and ‘data usage’ as search)
    • Once you check the above, on the same page, find and select 'Billing cycle and data-warning and make sure there isn’t a ‘Data Limit’ set that is causing you problems

Hi @christopherp.i740lr,

We’ve recently been seeing examples like yours on Samsung phones that have on Android Q. The Samsung battery manager is very aggressive about putting unused apps to sleep, and it does not recognize the importance of the Republic App for sending and receiving text messages.

In order to avoid the issue you’ve described, please add the Republic App to the Device Care list of apps to never put to sleep.

I’ve posted instructions here:

1 Like
Message an
Expert customer