Can't text my own goes to my coworker instead!


What phone do you have?
Motorola E4

What plan are you on?

Does your plan include data, or just talk & text?

Issue Description

When I text my own phone number (for notetaking), the texts go to my coworker instead. Even after deleting that contact, it still goes there. Any ideas?


Hi @brettc.r8k5fx,

Can you tell us anything further about any relationship your co-worker’s phone may have to yours?

Is it a Republic Wireless phone?
Was the phone previously on your account?
What text messaging app are you using?

Does your co-worker receive all your text messages, or only those when you text yourself?


I must admit, I never thought of texting myself as a forum to taking notes…that is quite clever.

Have you considered using an app such as Google Keep?
It supports a wide variety of styles of taking notes and lists etc, that is also synced with your Google account and will sync across any android device you have the app installed on.


There should be no relationship. His is an iPhone. It’s not connected to Republic in any way. His provider is verizon. I am using Republic Anywhere. He only receives my text if I try to text myself.


The issue isn’t how to take notes, it’s why my phone won’t text me own number. If that can never be done again, fine. I just want to know why.


It’s not an iPhone you gave/sold/loaned him or have ever used?


Hi @brettc.r8k5fx,

If you do a few of these texts-to-self (with apologies to your co-worker) how do they show up in your history in the online account portal? (The time give is in UTC, so it’s a little tricky to sort out.)
Do they show there as being sent and delivered to your own number?


deleted from both phone and google contacts

sync will replace it back…

and check to see if your contact, for yourself has your coworkers number
and have your created a contact for yourself… like “me”
my £2


I have absolutely no relationship to any iphone.


They show up in the chain of texts to him and from me.


Hi @brettc.r8k5fx, I was wondering how they show up in your logs in the Account Portal, but let’s set that question aside for the moment.

I have two things for you to try.

First, open the Android Settings app, tap Apps, and tap Anywhere. Then tap Storage, Clear data, and “Ok.”
You may have to restart your phone before you can launch Anywhere again after that step.

If your text messages continue to go to your co-worked, uninstall the Anywhere app, reboot the phone, and re-install Anywhere.


Hi @brettc.r8k5fx,

It’s been about a week since we last heard from you. Were about able to keep your text messages on your own phone with the data-clearing and uninstall/re-install steps I sent?



I’m still not ready to lose all my text messages. Is there a way I can save them easily?


Hi @brettc.r8k5fx,

Your text messages are actually stored in a database on the phone, and are just rendered in your text messaging app, they aren’t stored by the text messaging app. So the fixes I’ve suggested don’t erase the messages.

To be certain, though, I’ve taken these steps on my own phone.

  1. Check to see what my oldest text message is. I found one from 12/15/2016.
  2. Switch to the Messages app by Google :messages: as my default messaging app.
  3. Make sure that oldest 12/15/2016 text messages shows up in Messages. It does.
  4. Follow the directions I gave you above -
  1. Launch Anywhere, make it my default text messaging app, and see if that 12/15/2016 message is still there. It is!


Oh, that worked. Great. Thanks.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.