Can't use data on cell network

I just transferred from my moto x to a Galaxy S7, all my contacts and data have moved over to the new phone and I can receive calls with it. My only problem is that when I’m on a cellular network I can’t use data. I can still call or text, and can use the internet when I’m on wifi. I have mobile data turned on and I have a 1 gb data plan. What am I missing?


Please check this setting on your phone:

Settings
Connections
Mobile networks
Data roaming
Check that all the switches are turned ON
Then tap on Roaming guard
Turn OFF all the switches

See if you can now use cell data. When the phone updates, which it will do about once a month you will need to check these settings again.

If the steps don’t work, can you share your ZIP code, and whether you go the phone from Republic or elsewhere and then ordered a SIM?

When I enter mobile networks I can see data roaming but only as a off/on slider, I can’t enter it. It is on though. I also can’t find roaming guard, I have tried using the internet with data saver both on and off though and it doesn’t seem to have an effect. Also my zip is 67216. I bought the phone off ebay model G930U which I was told was supported. I just moved the sim card from my old phone to this one.

Under Data Roaming you should see two options just below the heading:

Roaming network

Roaming Guard

Then the switches - which should be ON

Based on what you’re saying I’m wondering is this could be a flashed phone. What does it say under About Phone?
Android version?
Model Number?
and Build number?

In the meantime I’ll check on your zip code.

UPDATE: According to your zip code you should have appropriate coverage to bring your own phone and use GSM network. This is according to RW coverage checker.

Android version 7.0
Model SM-G930U
Build: NRD90M.G930UUEU4BQJ5

When I go to Mobile Networks there is the switch Data Roaming which I have turned on. Below that is Network Mode, Access Point Names, and Network Operators.

By “bing your own phone…” did you mean “bring”? just checking if it’s a typo or if bing is a technical term I don’t know.

No, typo sorry about that. What you gave looks good.

If you tap on Data Roaming do you see more options?

Next thing to try is reseating the SIM card, do this with the phone turned off. If still no data or cell service we can reset the network or first try this app:

Once installed open the app, agree to everything and slide to Device+SIM. What does it say under Device Telephony Phone type?

No, if I push it all it does is turn data roaming off or on, even if I tap on the words and not the switch.

It sounds like you are not activated on cellular. Are you absolutely sure it is working for calling and texting when WiFi is turned off?

ok, how do you reset the sim card. Is this right?

First I would go outside, get at least 3 bars and restart the phone.

In Setting
Connections
Data Usage
Is Mobile Data turned ON?

Mobil Data is on

No that’s not it, turn the phone off and take the SIM card out and put it back in. Turn the phone back on.

Do as @seanr suggested. Make sure you don’t have any walls obstructing, if you can’t go outside at this time. Or stand/sit by a window. See if you get a signal.

Success! I went outside,got 3 bars, and restarted the sim card and now I get data. Thank you guys so much, sorry it was so much trouble. I seem to have a habit of having all the difficult problems so thank you guys again for your patience and help.

1 Like

Where did you purchase the SIM card? If you didn’t request a CDMA SIM card from RW, that doesn’t apply to your phone. It’s possible you’re on GSM. The app will tell you what you’re on. If you’re using your previous SIM card and it was CDMA then it needs to be paired with your new phone and that could be the issue you’re experiencing.

It just means that when you were in your home and activated, you did not have enough signal strength to activate on the GSM network. Our app worked over WiFi, but that is only part of the activation. With our GSM provider, the phone needs to be restarted when connected to a strong native(non-roaming) signal or it will never fully activate.

2 Likes

I’m using my previous sim card which came with my 1st gen moto x that I got a few years ago. I guess it’s not a CDMA then?

Message an
Expert customer