Can't use GPS, Google Assistant, etc

#1

Often after I leave home [and my WiFi] I can’t reach the internet, for instance Google Maps and the GPS or Google Assistant. It seems to me that the Data Saver is causing the problem but I can’t turn it off. I’m so frustrated that I’m looking at Apple!

#2

What model phone do you have?

If by any chance you have a Samsung, you should be able to find Data Saver in:
Settings
Connections
Data Usage
You should see Data Saver, tap on it and choose OFF

Also check if you have a Samsung
Settings
Connections
Mobile Networks
Data Roaming
Turn on all the switches
then tap on Roaming Guard
Turn off all the switches

#3

Moto X

#4

This article has photos of the menu to help with turning off Data Saver:

#5

No way to turn off Data Saver.

#6

If you press on the menu item, does another menu appear?

#7

Is the "Menu Item"the 3 little dots top/right? If so, that does not help.

#8

Swipe down the drop down menu 2 times
Tap on Gear in upper right corner
Tap on Data Usage
Give Data Saver a long press (1 or 2 seconds)
You should now see the option to turn off Data Saver

#9

From https://support.google.com/pixelphone/answer/7055392?hl=en:

Turn data saver mode on or off

  1. Open your device’s Settings app Settings app.
  2. Tap Network & Internet and then Data usage and then Data saver .
  3. Turn Data saver on or off.

When data saver mode is on, you’ll see the Data saver Settings app icon in your status bar and a notification at the top of your device’s Settings app Settings app.

Tip: You can add Data Saver to your settings bar. Learn how to customize Quick Settings.

#10

No Data Saver button to long press.

#11

Hi @georger.5w6e5a,

When you say you have a “Moto X”, if that’s what shows in the phone’s settings, then we’re talking about a Moto X 1st Gen, right?

Perhaps you have data restricted to these apps in the Republic Wireless app’s data controls.
There are instructions in this article to show you how to manage those settings:

2 Likes
#12

There is no Network and Internet button or anything else to long press.

#13

Which Moto X?

My G3 similar to the X1/2, phone Settings - Data usage - in the menu there’s an option to Restrict background data. It warns some apps won’t work w/o WiFi. Currently on the WiFi only plan and i can’t get to RW’s data settings to look futher.

:flight_departure:

#14

Are you sure you’re opening the Settings app?

ap_resize

To be honest, I’m not sure turning off data saver would do anything (if you indeed have data saver turned on). Foreground apps should still be able to access data with data saver turned on.

Can you take a screen shot of your home screen when you are experiencing the problem?

1 Like
#15

Let’s see if this helps:

Settings
Apps
Tap on Google Maps
Tap on Data Usage
Turn on Unrestricted Data Usage

If you see that Unrestricted Data Usage was turned off, you can individually turn it on for your apps.

#16

No doubt I’m doing the Setting correctly. Have done >1000 times. Phone is
several years old.

#17

What generation X is it? You can find the model number by going to Settings > About Phone

OR open the Republic Wireless app, what does it say for plan. You can find this under your phone number (please do not post phone number!).

For reference, please see:

#18

1st gen Moto X

#19

OK, no data saver on Moto X. To clarify, no Android Data Saver. This is done through the Republic Wireless app

Open the Republic Wireless app
Tap on cell icon
Tap on the bottom portion of the app
You will see all your apps listed
Flip the switch on for the apps you want to have access to data while travelling.

Please check the link @southpaw posted earlier.

2 Likes
#20

Please let us know how you make out.

Message an
Expert customer