Can't verify home wifi network

moto
refund_plan

#1

Moto E
2nd Gen
Refund Plan

Our Moto E phone seemingly connects to our home wifi network—shows as connected, can use Internet and see no cell data being used on Republic app—but the status of the phone consistently shows an error. It shows an orange circle/white triangle/exclamation point with the message “Verify Now.” If I click to verify, I am taken to a message from Republic: “Hello Internet. You are now happily connected…” but the status remains unchanged. Still shows the error, still shows “Verify Now,” and “Wifi calls & messages, no data.”

I have rebooted the router, the phone, rebooted the phone in safe mode, forgot network and logged in anew—nothing seems to resolve this error.

We also have a Moto G (1st gen), also on the refund plan, that has never had this error.

Hoping for additional steps to resolve. Thanks.


#2

Try uninstalling and reinstalling the updates to the Republic Wireless App.

Go to Google Play Store
search for Republic Wireless App
Tap on Uninstall -> Click OK on "uninstall all updates"
Once Republic Wireless App is uninstalled, restart your phone.
You might get an “activate now” and “download new version of RW app” messages…you can ignore them for now until you restart your phone.
On restart, again you can ignore the Activate Now message…and wait for the phone to prompt you
to install updates to the RW app…or you can manually locate in the Google Play Store -> Three horizontal lines -> My Apps and games and then tap on Update next to the Republic Wireless App.


#3

I followed the steps below to update the app, but I have basically the same
error‹this time a truncated version. I¹ve attached a screenshot.


#4

Something about your router is making the app and the phone, in general, thinks that it requires term acceptance like a public hotspot. Do you possibly have a guest side to your home network? Does this happen anywhere else?


#5

In the Republic Wireless App

Settings -> WiFi Settings -> Enable “Help me with extra verification”

As @seanr noted…it is unusual for a home network to ask for extra verification, so you might want to review your router settings, as well.


#6

Exactly–as if this were a wifi hotspot. This hasn’t happened elsewhere, as far as I know. This is a new issue for this phone (used to connect just fine). I did try the “Help with extra verification” setting change, but the issue is still there.

I discovered another issue that required me to open a help ticket so I have addressed this issue there as well. Hopefully it will be resolved. Thanks to you both for the help!


#7

Only on this home network. I’ve added another reply to this post–I had another issue I needed help with an opened a help ticket, addressing this issue there. I appreciate your help!


#8

I’m having the same exact issue…i’m curious if you got it resolved??


#9

You are having your phone act like your home is a public WiFi hotspot and asking you to verify the connection?


#10

I did, fortunately, but I can’t say exactly what did the trick. I tried a variety of troubleshooting steps like I mentioned above, rebooting the router again, rebooting the phone. I also changed the WiFi password more than once and after a new password and another reboot–the problem was resolved. I did take the other steps above as well (uninstalling and reinstalling the Republic app, changing WiFi settings) as well. In the end, the issue resolved after the WiFi password changes–I’d “forget” the network and log in with the new password. Maybe that worked because it was a “new” network connection?

Sorry I can’t be more helpful, but I was less than entirely methodical.


#11

sorry…have been away and using husbands phone, but very frustrated with this phone right now. so yes at home i get bombarded by pop ups that say “hello internet…you are gladly connected to” AND “xfinity login”.

used to work fine, but uninstalling/reinstalling didn’t work nor did checking the “extra verification” box in the repub wireless app/settings


#12

sorry been away…glad it worked out for you…hoping it didn’t come back for you??


#13

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.