CDMA activation problems

What phone do you have?
Samsung Galaxy S8
What plan are you on?
Clear choice
Does your plan include data, or just talk & text?
3GB of data


Issue Description

So, I already have a help ticket in but looking at the app reviews on the play store I’ve noticed that I am not the only one with this problem so I thought I would document it here as well. My mom recently upgraded to the galaxy s8 and the service at my uncle’s house was abominable so we requested a CDMA sim card which we received. After the fact I installed it and activated it assuming all was good. She gets a message at random times every day saying to restart her phone or to activate her phone. So this is what we have done in the ticket so far (and this is reasonable to try all of this. Note that I am getting a carrier signal and it does work sometimes but it also will kick me off periodically and I have to find a wifi network in range of the cellular network to reactivate which is dangerous since if my car broke down around the time this happened I would have no phone communication ability.

  1. Reset the state (get it to search for other types of network operators again)
    Type ##72786#

  2. Provide applications installed… this one is a bit annoying since I’m a tech geek so I install things on my parents phone to troubleshoot such as ampere and open signal but they told me to uninstall open signal (surprise that didn’t work) then I updated the prl and profile in settings (still didn’t work)

  3. Since the above did not work he also suggested doing the “VOIP” refresh (note that I have been able to call out using wifi since this trouble began so voice over internet protocol is not the problem, did it anyway) the code is ##8647## and the dial button if you want to continue following along.

  4. At this point the service desk did an internal change and asked to update my data profile (settings > system updates > update profile) I always do this in conjunction with a prl update so I did the prl update, restarted, and then did the profile update and restarted again.

  5. Now the old great solving method of nuking everything, they asked me to do a custom factory reset using ##786# instead of the regular way through settings. After backing up her messages and phone log (the only 2 things that don’t automatically back up) I did the reset which did not help

  6. Currently there is a response saying to contact Samsung for hardware replacement. Since the phone is connecting to Sprint towers with no trouble I am completely sure that this is not a hardware problem so I tell them this and they are going to send me another sim card I guess.

This is a long of my full interaction with the help ticket crew at this point and they are very nice and have some good ideas to check, at this point I’m pretty sure that the sim card just isn’t whitelisted in the republic system, any other ideas to try? Attached is the picture of my diagnostic screen (ignore the million wifi warnings as I am at a place with a limited wifi connection)


Note the “Network Operator” problem

Hi @alleriodrone,

I’d like to look into this for you, but I’m going to be unavailable most of this afternoon, so I won’t be able to give you immediate responses.

Could you please give me the ticket number.

Additionally, could you go a step further in the diagnostics to “Show full logs” and, without posting a screenshot, because there’s some personal info in the full logs, tell me what number it shows by the Network Operator FAIL output?
image

This is not an indication that the SIM card isn’t right, but rather than the info we’re getting from the tower doesn’t match what we’ve been told by our carrier partner to expect.

Typically this does not cause the issues you’re seeing, though.

The ticket number is 1685738. next to network operator it says 312530. I am switching it back to the GSM sim for the moment since some signal in most places is better than no signal anyplace so please let me know if that helps you at all.
(I also took screenshots of the full “Advanced diagnostics” just in case you need any more information from that.)

Ok, thanks. I’ve added some notes to your ticket and asked the team to take another look. Don’t let that diagnostic be your primary focus, let’s focus instead on the actual issue the phone is experiencing, so the team can work toward solving that.

Alright, thank you. I did also switch the phone sim back to the gsm sim in the meantime so it can be used at least where that does give her signal.

I did put the CDMA sim card back in, I got the same network error code that I entered before. Since they seem to think it is updated and should be fixed I did leave the card in but if it deactivates tomorrow I’m going to say that this solution either didn’t work or there is another problem. I still find it interesting that it thinks “I’m Sprint” rather than “I’m Republic” when I looked at the diagnostic it is still thinking that it is Sprint under Network operator name while when I run the same diagnostic on my Moto X4 it says that the network operator name is republic (I changed my sim to CDMA as well a while ago)

Hi @alleriodrone,

Does this look at all like it might be what she was experiencing when the phone “deactivates” at work?

That might be the same issue but those steps were suggested very early on in the help ticket and it did not help.

Rechecked the second link, all of the data options are also ok, I guess that was a step that wasn’t mentioned in the help ticket yet.

So, update time. The phone still does not work for even 24 hours without going into activation mode with a CDMA sim card, has the same diagnostic screen (Though according to the help ticket guys the diagnostic screen is a bunch of jibberish, all that matters is that the phone connects to the network), and is back on GSM without a problem… This would point me to the solution being software in nature (since LTE works and all networks use very close frequencies to each other for LTE). If it were a hardware issue the phone would not even connect to the towers. My other argument is that if it were a problem with the slot where the sim card plugs in or a sim card placed incorrectly the GSM sim would not read and get a signal at all so between those two justifications I am 98% it is not hardware related. This leaves software on the phone or the networks software, the phone can easily connect with GSM towers and connects to Sprints towers as a Sprint phone (for some hours without a problem) so I think that leaves us with the connection between the phone and Sprints towers, any ideas that I can try or is the connection most likely messed up on the tower side?

Hi @alleriodrone,

I see that your ticket has now been attached to a master ticket as a “known issue.”

I spent some time today discussing your issue with one of our engineers. He had some thoughts and questions.

  1. Where has the prompt to re-activate happened? I was thinking it only happens at her workplace, but has it happened elsewhere?
  2. Is that Diagnostic network operator error unique only to the locations where the prompt to re-activate happens, or do you see the same error and network operator identifier (312530) at places where the prompt does not kick in, as well?
  3. When at work, what is the Wi-Fi environment? Were you at her workplace when you took the screenshot you posted above?
  4. When you are in a location with that network operator identifier, and turn Wi-Fi off, does the phone indicate it is roaming?

Once we understand some of these details, we could do some testing with you, if you want to. One test would be to replace the CDMA SIM card and see if the issue persists. This would indicate whether it’s simply a bad SIM card.
We could send a loaner phone (identical model and software versions) and test it with the existing SIM card. This would indicate whether it’s the individual phone.

If the issue persists on a new SIM card and a different, identical phone, then it’s a software problem. The modem software in use when a GSM SIM card is installed is different than that in use when a CDMA SIM card is installed, and there may be a problem in the modem software that only arises when a CDMA SIM card is present.

Answers to specific questions:
1.) The prompt has happened in Traverse city, the many workplaces she goes to (she works for the post office and is at a new office almost every day so the location is not the problem), it happened at home twice (not as big of deal since she has wifi there and restarting actually fixes the issue when wifi is present).
2.) same network issue and prompt universally present (tried running it like 7 times when I was on my way between Ludington and Kalamazoo the other day at various points)
3.) No wifi at work, nope the screenshots I’ve taken have all been from home since it is my moms phone and she does not know how to take screenshots (I’ve tried to teach her several times with no luck). By home, I mean either Schoolcraft, MI or Freesoil, MI where we drive between on weekends.
4.) nope, it does not indicate roaming, it shows that it is on the Sprint network though which means that it is acting like Sprint is it’s home network (Yes, I know that Sprint is technically its home network on CDMA but it usually is aliased as Republic)

Follow-up question: I’ve tried swapping the Sim with an old one that was in her Moto G6 and it said that it was tied to the G6 and wouldn’t work with this phone, could we untie it and try that as a secondary sim since I know that it was able to connect correctly before.

What was the exact wording it uses to say that it was tied to the G6?

Our SIM cards expire 20 days after they are deactivated. How long has it been since the G6 was replaced?

It’s been much longer than 20 days, I’ll just leave it there, I tried 3 still cards from 3 phones so I don’t remember the exact wording from each one right now. I can try it again in Sunday and get back to you.

@alleriodrone,

No need to go out of your way to see what the language was, I was just curious because if the SIM card has been deactivated, it’s no longer tied to any specific phone, but if it’s been deactivated more than 20 days, it has expired.

Is the G6 still functional? You could put the CDMA SIM card from the S8 into the G6 for a similar (but inverse) experiment.

The CDMA SIM card would need to be deactivated to move from phone to phone, which would be accomplished by putting the S8 back on the GSM SIM card.

I’ll be glad to give you an activation coupon so you can test at no cost, if you think that would help rule out that something is wrong with that specific CDMA SIM card.

1 Like

Hi @alleriodrone,

Our engineering team has alerted me to the fact that the S8 has received an Android Update, and they would like to know whether that update has solved the loss of connectivity your mother was experiencing. Has her phone recently updated to G950U1UES5DSF3?

If so, and if you need a fresh CDMA SIM card in order to test, please let me know.

1 Like

I’m actually not near her phone this weekend, I can check on Monday, I don’t remember when I put that dim card in last so I couldn’t tell you if it is expired until I try it. I’ll get back to you Sunday, thanks for the update

1 Like

Updating now, it’s saying invalid sim card so I think that the sim card is expired.

Quick update: updated to the G950U1ES5DSF3 but the sim shows up as invalid in the republic app

Ok, let me get into the ticket and get a new SIM card out to you. I’ll need address confirmation in the ticket before I send.

2 Likes

Hi @alleriodrone,

I did send the SIM card out, but in the meantime, we had a few other people experiencing the issue confirm that the update did not solve it. Please keep the SIM card handy, but don’t activate it yet, and I’ll let you know when there is further news.

1 Like

Ok, I put the sim card in my desk and have discourse on my phone so I should get any updates pretty quickly

1 Like
Message an
Expert customer