Cell Data Suddenly Stopped

What phone do you have?

What plan are you on?

Using Moto G6 and CDMA Sim
Am on the My Choice + 1 GB plan
Have app cell data 800MB available


Issue Description

I recently returned to Republic from another carrier. They determined CDMAwas best for my area. Got a GSM card and installed, followed by CDMA. All went fine. Been using cell data in places I wouldn't have before when I was on GSM.

All has been fine until today when I no longer had Cell Data available. When I turn off wifi to check I get the little T-Rex saying “No internet” and the option to “download when online”.
Went into the Republic app. and saw Data Freeze was now activated. That was not something I did.
Toggled Data Freeze off on and off, then restarted.
No difference. Data freeze is still off but I continue to get “No internet” message when I disable wifi.

As I said, this just started this morning. Until yesterday I was getting data just fine and I have not made any changes to settings except toggling the Data Freeze on/off.

Has there been an update or something?

Also, with the CDMA should I be using Global or the “recommended” LTE? I have tried both as well as 3g. No impact on the “No internet” situation.

Thanks!

Hi @fat_finger_mike,

You should leave that setting as it was.

To confirm, you are presently in an area where cell data once worked? Also, in addition to verifying Data Freeze is off in the Republic app, have you verified Airplane mode is not engaged and cell data is on in Android settings?

1 Like

Thanks Rholand,

Yes I should have mentioned those. Cell data is on and airplane mode off. It It was set to Global for the Internet Type. As I said tried 3G and LTE and it is now back to Global. None of those settings made a difference.

I am on the same path I take at the same time: on my way to work so I would have expected similar reception. Even in areas I know are very strong still nothing.

Hi @fat_finger_mike,

Thanks for confirming all that. I didn’t want to send you down a troubleshooting rabbit hole. I suggest trying a network settings reset as the next step:

Thanks again. Did the reset, re-entered my wifi password but to no avail. Still only getting data with wi-fi. I will give it some time and try again.

Hi @fat_finger_mike,

There’s a next step:

Again My Great Thanks rolandh

Am connected to wifi. Tried that but do not have Carrier Settings as an option. FYI my Moto G6 is on Android 9. Republic confirmed this address as a CDMA preferred address.

Just another bit under Mobile Network it does read “Republic”.

That’s interesting as I just walked through those steps using a G6 Play (close as I can come to a G6) also running Android 9 Pie and they work for me. There’s one more thing to try:

1 Like

Been following and this and have a quick question. Almost sounds like the phone does not have an activated CDMA SIM. Would it be worth verifying if the phone has an activated CDMA or GSM SIM?

Both of our G6’s are running Android 9 Pie and are activated on GSM…so of course there is no Carrier Settings in the Update Data Profile steps given in post 6. My understanding that the phone must have an activated CDMA SIM for the Update Data Profile steps to work.

It’s a quick check and I could be totally out in left field :upside_down_face:

It is not an unreasonable suggestion and something I considered. Based on @fat_finger_mike’s original post, he seemed very confident he has a CDMA SIM and it’s not unheard of for the Update Data Profile option to go missing:

The suggested fix for that is to first reset cellular settings.

Thanks to all so far but issue still exists. I tried the Reset cellular setting by connecting to WiFi and dialing * # * # 72786 # * # * . Get a Republic message that number dialed is not allowed.

In checking the settings it DOES say CDMA. Also I pulled the card and it is, in fact, the gray text as opposed to the green text.

I still cannot get to that Carrier Settings when trying to update the data profiles.

As I said, all was working just fine until this morning. Took the same route to work. And now home and when I turn off wifi I continue to get No Internet Connection.

I really appreciate all the thought and effort here.

OH - just thought to make a screen shot of the status bar at the top. It may show something useful.

removed original - roaming data was turned off from the last reset. Here is the current status with roaming turned on:

g6-status%20with%20cdma

Hi @fat_finger_mike - I know you’ve checked and confirmed a bunch of settings. How about checking one more?

On our GSM activated Moto G6’s - Settings>Network & internet>Data Usage
Under Mobile – make sure Mobile data is toggled on.

Who knows, somehow the Data Freeze got toggled maybe this one did too. My apologies if you have already checked this and I missed it in the post.

Yes. I checked that earlier but just checked again and Mobile Data is indeed toggled on. Your help and everyone else’s is really appreciated.

@fat_finger_mike - Maybe it’s time to step back and do a simple hardware check. Find it hard to believe that it is a hardware problem from the screenshots you shared, but the tests are available in the Moto Help.

Icons%20-%20Moto%20Help
Moto Help>Device diagnosis>Hardware test>Cellular network

Would be strange to have good cell bars AND have a cell hardware issue. But a test would be one step in the process of elimination if you’re willing :smiley:

Don’t want to go down the rabbit hole but starting to run out of ideas :crazy_face:

Things seem to be fixed now. Went through everything a couple more times and then realized I had hit the call button on that * # * # 72786 # * # * code. I just entered the code and waited a few seconds and it prompted me to reset. After it completed the reset I went into Settings and turned off wifi. In a second or so the LTE signal appeared next to the triangle and I was able to cellular data. And yes, I turned the wifi back on! LOL

So again my heartfelt thanks for all the kind folks who assisted!

Oh! And now I get Carrier Settings under the Advanced Mobile network.

1 Like
Message an
Expert customer