Cell network operator not one of Republics and can't answer call when already on call

What phone do you have? Moto G7

What plan are you on? My Choice + 1GB

Does your plan include data, or just talk & text? Data, Text, and Talk


Issue Description

I first noticed a problem upon the last update (?? a couple or three weeks ago). First, if I'm already on the phone, I can hear that someone is calling, and if I sign in, I can see who is calling but there is no way to answer the call while I'm already on the phone. So I ran a diagnostic and I come up with the message: cell network operator not in Republic network. It suggests that I may not have a Republic SIM card, but I do. Any suggestions as to what may be wrong and how to fix it?

Hi @rasbyp.d30zlo ,

Let’s ignore the diagnostic result for now. That diagnostic result is based on a finite list of cell operators that isn’t always updated as quickly as new cell codes are created.

So you’re in a call, and you hear a second call, which would be call waiting, right?

I’m not follow what this part mean. What are you signing into at that point?

Where do you see it?

What is on the screen?

1 Like

When I’m already on a call and a second call comes in, I have to put my identification code in to even see who is calling to open the phone. I didn’t used to have to do that because it used to just pop up on the screen.

Once I put my identification code in, it simply takes me to the home screen which has no indication of a call, so I click on the phone and then recent phone and can see who called, but can’t answer it even if it is still ringing.

So basically, I can hear the phone ringing but can’t get to a place to put the other person on hold and answer the call.

Do you know how long this has been happening and what might have changed since then?

If you’re not already in a call, the inbound call rings normally and you can answer without unlocking the phone, right?

Are you absolutely certain that it’s a call, and that maybe some other notification, like a text message or calendar alert hasn’t been assigned a long ringtone instead of a short notification tone? Or that it’s not an alarm?

It’s only changed within the past 3 weeks or so; I believe with an update. It’s a call as I have my notifications set to a completely different sound than the phone. I have a regular phone ring on my phone, plus I can see when I go into the phone app that someone has just called.

Ooops, forgot to answer. Yes, the phone rings as normal for the first call. It is only when there is a call waiting that I can’t get to it.

If you open the Play Store app, do you have any apps that need to be updated?

When I check, it says “no problems found.” Now that I think about it, all of my problems started when the “visual” update happened. So instead of the three symbols across the bottom, it is now a swiping action (which I think is more of a pain than a benefit). But that is when my phone started acting up. I forgot to mention that my microphone sometimes stops working mid phone call even when it is the original call. I can still hear them, but they can’t hear me.

I also get “cell network operator not in Republic network.” and the suggestion that I may not have a Republic Sim. I first became aware of this when visiting family in Portland Oregon and getting slow or no data. So I ran the test. Now back home in Colorado Springs area (where I am getting cell data OK) I decided to run the test again and again got the same message.

I have a Moto G5+ with a CDMA sim. With previous phones, I would update the PRL but can’t find a way to do that with this phone and don’t know if that would fix it any way.

I do have all apps updated. I ran a cell tower ID app which said I am connected to a Sprint tower with Republic service.

Any thoughts? Do I have an issue? Semi unrelated, I have wondered about trying a GSM sim because I get basically no coverage when traveling through long stretches of I-80 in Wyoming where I “should” be able to at least have voice roaming according to maps.

A couple of weeks ago, I also had an odd experience with my Samsung S10 after a software update. I would be having a conversation on the phone and it would disconnect and a message would appear about not being on network and then a call would ring through I would answer it and it would be the person I was talking to and thought I was disconnected from. They never noticed a thing and I would have to ask them to repeat what they just said. I had a chat with a Republic Expert and my phone had the microphone set properly, etc. Finally I just turned it off and turned it back on again and it never happened again.

@Stuckin79,

What you’re describing is very different, and will likely come back once the app triggering the conflict is used for the microphone again.

@royrose,

Are you experiencing any specific issues now? If not, just disregard that diagnostic result. It’s not meant to be a way to look for things to worry about, but a way to identify potential directions to investigate when there is an issue at hand.

I’m not sure you and I are looking at the same thing. Is this where you checked?

Let’s try setting that back to the three buttons, then. I think the instructions are the same on your phone as on the G Power, but you can let me know if this doesn’t take you in the right direction:

Do you see an error message when that happens?

Yes, I am going to the play store and using the three horizontal lines. So, it appears all updates are in place.

No error message when the microphone stops on my end. However, I took my case off last night and haven’t had the same problem so far. Maybe the case was pressing something?? Additionally, this morning, my call waiting worked after removing the case??? That doesn’t even make sense to me, but I’ll continue to monitor.

I’ll try setting it back to the three symbols at the bottom and try that.

No issues here now. Just had poor coverage in Wyoming (voice and data) and Oregon (voice OK and data poor to non-existent) which led me to check. I’d like to have better coverage there in the future.

Very good troubleshooting!! What kind of case are you using?

On the outside, it says: Encase. On the inside, it says: Impact Dispersion System. It’s quite stiff and had definitely prevented damage during a couple of drops, but it is very tight which makes it difficult to get on and off.

Thanks @rasbyp.d30zlo ,

I checked to see if we have any overstock cases for your phone, (and wanted to be sure any I found wouldn’t be the same kind). All we have are a clear, flexible TPU case by Avoda. I’d be glad to send you one, but it sounds like you may want something more substantial.

Please let us know if the “fix” sticks.

1 Like

Thanks, I will. It seems to be working so far.

1 Like

My guess is that the case had multiple problems and that one of them was that it was covering the proximity sensor on the device making the phone think it was up against your ear when answering the second call causing the symptoms your were seeing in trying to pickup that call.

Thanks, that makes sense.

1 Like
Message an
Expert customer