Complaint about a recurring problem - Cellular network not available for voice calls

calling

#1

I used to be the biggest Republic Wireless evangelist there was. I live in a place where there is no cell service at all (National Radio Quiet Zone), so wifi calling is really the only thing I can do, until I travel. The areas I travel to don’t have the best coverage for republic but hey I can use it with WIFI and that’s what I love, also love the inexpensive bill.

But there has been a recurring problem that is not predictable, and will go away after a time, or a few resets or something, but it keeps showing up to the point where I am seriously considering looking for a new company. I’m writing this in hopes that a developer or somebody at the top will read this and FIX THIS PROBLEM because I know I’m not the only one who has it, and there’s no point in me opening up another help ticket again because I know what they say. Also, it goes away, but it comes back later. The help ticket people only focus on solving the short term problem, not the long term problem.

Here is my main issue: the dreaded “Turn off Airport Mode to make a call”, when I know full well it works with airport mode on and wifi enabled. That’s how I make all my calls, since there’s no point in keeping the cell data on and searching constantly for no signal, and destroying battery life. But to humor it when this happens, I’ll try turning off Airport Mode. Then it says the STUPIDEST thing that a republic phone can say: “Cellular network not available for voice calls.” Well no kidding. I NEVER have cell coverage — THAT’S THE REASON I SIGNED UP!

Just to preemptively answer those who assume I don’t know any better: yes, wifi is enabled in either case, and yes, I have internet (I’m on the internet as we speak, and the problem is manifesting itself again).

I’m not interest in ongoing short term fixes to this problem. I want this problem resolved indefinitely. I’m not sure how much more I can take it.

An aside, another serious problem but not quite as infuriating as the one mentioned: often times people have called me and instead of ringing or going straight to voicemail, they just get a message saying “The subscriber you are trying to reach is not available. Goodbye.” I don’t even know they have called except a few times someone has mentioned this to me later. Who knows how many more important calls I have missed because of this. Seriously, Republic, get your act together, or I’m hitting the road.


#2

Hi @timothyh.tdevf1,

Both of the issues you’re describing - inability to make a call on Wi-Fi and inability to receive a call on Wi-Fi would point to the fact that something is interfering with your phone’s ability to communicate with our servers. This can be cause by an app conflict or something about your network. We have Community members who would be glad to help you troubleshoot your network, but there is nothing we can do on our end to keep your phone connected to our servers if something is interrupting that connection.

It sounds like your callers are hearing the default voicemail message. “The Republic Wireless member you have called is not available. Please leave a message after the beep.” It does not end with “Goodbye.” You can record a different greeting in the Republic Wireless app.


#3

I do have a voicemail greeting set up. So does my wife and I have had the same problem with her as well. I know how a voicemail is supposed to work and I’m telling you that it does not always work. Perhaps it does not say “Goodbye” at the end, but something like “Try again later”. I can’t remember it word for word but I do know that it does not give you an option to leave a voicemail, instead just hangs up after the robot voice stops talking. I also keep my voice mailbox empty, so it is not a space issue.

There is nothing wrong with my network or my apps. I’ve had this problem off and on since starting my service again and it is completely unpredictable as to when it will happen. If it was a network or app problem on my end it should be predictable, because I know when my network changes and when my apps change or update.

Honestly I’m weary of opening help tickets that only solve my problems temporarily, only to have them resurface months later for no apparent reason. BTW Republic isn’t the only company with wifi calling . Maybe other people don’t blend it the same way, but obviously it isn’t working right for me, so it might be worth it for me to test someone else out


#4

Hi @timothyh.tdevf1,
As one of the many Community users that would like to help figure out how you can have good connectivity for your Republic phone I will start with a couple of questions

  • Which phone are you currently using?
  • Who is your ISP (Internet Service Provider) and which modem/router are you using? (Make/Model/Version if possible)
  • Are their other WiFi users near you that your phone detects when you authenticate to your router?

#5
  1. Moto G4
  2. ISP = Spruce Knob Seneca Rocks Telephone, Router = TP-LINK Archer C7 SN- 2151735005581
  3. There are other wifi users near me (my laptop for one, and some other devices), I don’t know if the phone detects those or not.

#6

Thanks for the quick response … could you check the Version? https://www.tp-link.com/us/faq-46.html and post back the speed that the local telco is providing (is it wired to your house or wireless (WISP)?


#7

Have you run a speed test to determine your ISP connections Ping, Latency, and speeds?
According to that ISP website, their packages are only 1 and 3megs upload speed, which is extremely low. At such speed, even the slightest network traffic would completely saturate your upload bandwidth. Which would cause issues with VoIP for sure. Also, a high ping and latency also is known to cause issues.


#8

Speed test - ping - 11 ms download speed is at 14.78 Mbps and upload is at 6.06 Mbps

router version - 2.0

I think it is wired to my house

There may be some other people on the network but I’ve had this problem before with zero other network activity. Like I said, not predictable.

Interested in the high ping thing…don’t know what that means. Are my speedtest numbers helpful?


#9

Interesting, I must have found the wrong ISP webpage, or it is not up to date.

Your speeds should be fine for VoIP then.

Do you have an VPN, security, firewall, anti-vrius apps installed on your phone?
Those will block or interfere with how the R.W app and services work.
If you have any, remove them and see if that helps.

Further more, try booting your phone in Safe Mode, and use it for a while, as this disables all third party apps and can help determine if it is an app on your phone that is causing the issues.


#10

I wouldn’t be suprised if the ISP webpage is behind the times. Where I live that’s to be expected. At least the service is fast, right lol.

No VPN, security, firewall, or anti-virus apps. Will try Safe Mode. I’ve already tried refreshing my activation a bunch of times (i know you didn’t suggest this but it’s something that people usually tell me to do when this problem occurs)


#11

In Safe Mode and still having same problem. With Airplane mode off, wifi on, “Cellular network not available for voice calls” (again, I never have cell service here, so not sure why that would matter since my wifi is working fine). With airplane mode On, and wifi enabled (my preferred mode of calling, which generally speaking works, except when it doesn’t), “Turn off airplane mode to make a call.”


#12

i should mention, I have been receiving and sending Texts fine today while this calling problem persists


#13

Other things I have tried today:

-Turning off/turning back on airplane mode and turning off/on wifi, various combinations of doing so
-refresh republic wireless activation (by dialing * # * # 8647 # * # *)
-rebooting phone
-rebooting in safe mode
-disabling/re-enabling all Republic App permissions
-republic app advanced settings>Reset Degraded Service Checks
-uninstalling/reinstalling the republic wireless app
-calling my phone via other number (using an app on my computer to call over wifi) – in this case, interestingly enough, my computer was able to ring the phone and connect with my voicemail. The whole time I watched my phone, it never registered the call, never rang, and never gave me a voicemail notification when I was finished.

none of these things have changed my problem.


#14

Does the ‘problem’ occur after the phone has been at rest for ~60 min or more? (if so the Google Doze has kicked in and killed the WiFi) … but there are ways around that


#15

#16

I have seen this several times. It is usually just a brief annoyance, but annoying all the same. (Moto MXP/GSM network).


#17

I was having the same problems described by timothyh right down to the “caller not available” and not being able to leave a message. I read further through the replies and something stood out. I had installed an app “Wayfair” around the same time I noticed my phone issue. I just uninstalled it and I no longer seem to be having issues. Time will tell. Just wanted to pass along my experience.


#18

Thanks for that nicole. I didn’t have that app, and like usual when this happens to me, it was fine the next day without me uninstalling any apps or anything. If an app was conflicting then perhaps there was an update that night/morning that changed things. All I know is that the phone didn’t work all day, up until I went to bed around 9 or 10pm, turned off the phone for the night. In the morning I turned it back on and it worked no problems. no idea. And I had tried turning it off and on again several times during the day so I have a hard time believing it was turning it off at night that did it (though I turned it off just the same, just in case it would help). Who knows. I can never figure it out. It will happen again in a few months and I’ll get mad again and then a day or two later hopefully all will be well again. I guess that’s just the tradeoff I have to live with for republic’s inexpensive bills, which I do appreciate


#19

I have been having the same kind of problem since bonded calling came out in the Lollipop OS. (2+ years, 4 different phone models, 6 different phones). The problem seems to go away whenever there is an upgrade on Republic’s side of the system. I suspect it reappears after a poorly tested Google upgrade is sent down. Republic’s price point is low enough that I have decided to keep this account, but I have accepted that I will need to join the dark side and get a phone with one of the Big 3 in order to have a reliable service. The last straw for me was having to dial 9-1-1 three times to get an intelligible connection. The help department has given up and actually suggests I change carriers.


#20

I have this problem sometimes too. Though in my case I have no cellular service where I live so I keep Airplane Mode on to save battery life. In cases where I run into the problem, if I turn AP off I still get the “cellular service not available” notification. Sometimes it just won’t use WiFi. I’ve found that if I go into Apps and Force Stop the Republic Wireless app, then when I go to make the call it restarts the RW app and the call goes through.