Conference Call Automatically Starts When I Answer a Call Waiting Call

Moto G5 Plus
My Choice
1 GB data plan
Operating on CDMA Sprint network
Android 7.0
Republic Wireless app version 3.20.2.1

Checking the community to see if anyone else is experiencing what I consider strange call waiting behavior while using my phone on the cellular network.

I was on a cellular call with a friend today and heard the familiar call waiting beep. It was my wife, so I answered to tell her I would call her right back. To my surprise, a conference call was started between the three of us. I found this very strange, but thought it might be a one time fluke or that I bumped the wrong button. That was, until I was able to 100% replicate the behavior with a few co-workers. I started a call with one and then had another call me. The same thing happened - I heard the call waiting beep and answered the call…and the three of us were joined in a conference call. Weird.

I then joined my office wi-fi and tried again. This time, the caller ID functioned as I expected. I was able to put my in-progress call on hold and answer the other call. I could switch from call to call with ease and I had the option to merge the two calls into a conference call.

I repeated this experiment a few times on both cellular and w-fi with the exact same results. Answering a second cellular call immediately started a conference call. Calls on wi-fi functioned as I expected call waiting calls to function. Rebooting my phone, VOIP-ing, and resetting cellular activation all had no effect. The behavior persists.

Has anyone else experienced this? Is this normal call waiting behavior for Republic Wireless?

I haven’t seen this mentioned, and I don’t think that would be the expected behaviour.

  • With the complete detail and steps to replicate the problem you have provided here, you might want to Open a Ticket and let Republic know about it

Thanks for the advice. Ticket 1404919 is now open. Will advise when this is addressed.

1 Like

Just as an aside, in case your not familiar with it…

Are you aware of the “Quick Response” feature on Moto Phones?..(get those a lot with my Ex).

Dialer/Menu/Settings/Quick responses.

Thanks for the reminder. Am I Familiar with the feature? Yes. I don’t use it much though. Besides, the feature would have been useless in this case. My wife’s call originated from her office desk phone. Help Ticket response still pending.

1 Like

I just chatted with a Republic Wireless customer service rep because call waiting was not working. I just got my service last weekend and hadn’t noticed until somebody complained about not being able to reach me. I was told Republic Wireless DOES NOT OFFER call waiting. But it sounds like that is not true? I am very confused.

I can’t speak for anyone else, bradams1974, but I definitely have call waiting. Per this thread, it works great when on wi-fi. But not so much when on cellular. There are differences in Republic phones and service though. I have a 3.0 phone (Moto G5 Plus) with a My Choice +1GB cellular data plan. Also, I am on Republic’s CDMA partner cellular network (Sprint). Features may be different if you have a different phone, different plan, or are on Republic’s GSM partner cellular network (T-Mobile).

Sounds good, thank you.

Update. Ticket is still open. Republic support confirmed that this is odd and asked me to try two things: 1) wipe the cache and 2) factory reset. Neither corrected the issue. Also, my wife’s Republic phone (also a Moto G5 Plus with Sprint cell service) exhibits the same behavior. It would appear this is not isolated to just my phone. Anyone else out there have a Moto G5 Plus on Sprint willing to experiment to see if you have this issue too?

I have a 19 yr. old with a G5+ I can ask to experiment, but getting him to take the trash out/mow the lawn is tough…but I’ll try.
:grinning:

1 Like

Update. I am pretty sure I have Republic support baffled with this issue my wife and I are experiencing with our two Moto G5 Plus phones. Here is response I received from support a few days ago:

“We will be leaving this ticket open. This issue has been brought to the attention of another team to investigate and test the issue in order to resolve it for you. We do want to advise you that it can take some time for us to find a resolution for the issue and implement a fix for it.”\

Actually I read the response you posted as a good sign. :star_struck:

  • They did not auto close the Ticket
  • It has been escalated to another team to investigate and test … this usually means it has been escalated, not a sign of lack of expertise … but narrowed down to where it can be pointed to those with broader skills in a particular area
  • They set the expectation that it may take time to resolve/fix … very normal for something as unique as your problem appears

@ryand.wsr2ce Was support ever able to figure this out? If so, can you share what they told you regarding the cause? Did you have to change anything on your phone?

Below is the response I got from support. Basically the issue was confirmed with no solution yet.

"As of right now, I took your issue and was able to reproduce it on our lab phone so I created a bug for it and sent it over to our developers.

Right now, we are trying to understand if a update to the system software is what is needed to resolve this issue. However, this could take some time as we have limited resources when it comes to our developers."

I’m sorry to hear that. Hopefully they’ll be able to get it tracked down and a solution implemented for you on this.

Posting to prevent this topic from closing automatically. Still experiencing this issue. No response on help ticket 1404919 for over 3 months now.

Hi @ryand.wsr2ce ,

I’m sorry to see you have not had another response on your ticket in several months. I’m afraid the bug is a very low-priority issue, as you are the only person who has reported it and our technicians were unable to replicate it.

Could you tell me what Android build and RW version are on your phone?

1 Like

I find your reply condescending. And it certainly is not accurate.

This issue I am experiencing was indeed replicated on a Republic lab phone and the bug was acknowledged to me by support on July 19th. I don’t know what the lab phone is running, but mine and my wife’s phone are both Moto G5 Plus phones and both exhibit this issue. We are currently on Android 7.0 Build number NPNS25.137-93-18 running app version 3.23.0.65.

Whether others are reporting the issue or not, this is still a bug that was acknowledged by the help team 3 months ago. I have not been impatient. I have not been demanding. I fully expected this to take some time. As a longtime Republic customer, however, the last thing I expect is a dismissive attitude like this when issues are reported or being discussed. This makes people like me want to leave. A low priority issue to you is still an issue to me.

FWIW, below is the exact response I received on help ticket 1404919 on July 19. There has been no update since then and the ticket remains open.

"Hi Ryan,

Thanks for the question and patience.

As of right now, I took your issue and was able to reproduce it on our lab phone so I created a bug for it and sent it over to our developers.

Right now, we are trying to understand if a update to the system software is what is needed to resolve this issue. However, this could take some time as we have limited resources when it comes to our developers.

Let me know if you have any other questions.

Thanks,
Chris"

Hi @ryand.wsr2ce,

Please know that there is nothing condescending about what I’ve writen. I’m trying to help, and have already notified the team responsible for the bug that you continue to experience this issue. I know sometimes it’s hard to know “tone of voice” when there’s no voice or body language to go with a message.

Yes, the issue was reported as replicated by the first agent who replied to you. Since then, however, a technician tried and was unable to replicate the issue. This is why I wondered if a recent update to either the Android build or RW app might have solved the problem.

I’m not dismissing that you’re having the issue, nor that it needs to be fixed. Our app developers and engineers, however, must prioritize their work based on the impact. I agree that the issue is valid and worth fixing, and that three months is a long time to wait. I’ve been that person who is the only one to report an issue, and I know how frustrating that can be.

I do apologize that no one got back to you when our technician reported he could not replicate the issue.

I have updated the bug with your Android build version and RW app version. We might also need to explore what other apps are on both your and your wife’s phones that might be missing on our technician’s phone.

Having some additional people test this and report back in Community would be extremely helpful, as well. If anyone else can replicate, please open a ticket and ask that it be attached to master ticket 1412009.

Hi @ryand.wsr2ce,

Our technicians have spent some time this week trying to replicate this experience and still have not been able to. Could you tell us if the merged call only happens when you and your wife are two of the three callers?

I’m also curious to know if the same thing would happen if the phone is in Safe Mode.

Message an
Expert customer