Connected to Router but No Internet

Hi,
I’ve been having issues with internet. I can connect to it, but then it indicates there’s no internet. All the while, I know that there’s internet because my laptop is currently connected to it. I didn’t have this issue with my old phone, but the new one hasn’t been able to receive internet yet.

I’ve tried resetting the network settings on my phone, restarting the router, trying the WPS push button, restarting my phone and messing around with a couple other functions but nothing seems to work.

I’ve written with another expert and they suggested asking here.

Thanks for the help!

Hello @kristofferp.sqordi

Welcome to the Community :slight_smile:

It looks like you tried some good troubleshooting steps. Here is a Republic Help article that you might look over. Some if its suggestions you might not have tried. :wink:

By the way… is this happening only on your home WiFi? Have you tried to connect to any others?

please let us know how it goes :slight_smile:

Hi @kristofferp.sqordi,

Have you been able to get your phone successfully connected to your network yet?

Hi SuperT,
Thank you the link and suggestions and my apologies for my delayed response.

I looked through the link and have tried the following:

  1. I’ve checked if there are antivirus apps that could be interrupting with wifi and don’t see any.

  2. I’ve tried resetting the wifi and forgetting it and then rejoining

  3. Last I checked, I can still connect to WIFI at other locations. I used to be able to connect to this WIFI with my old phone, but the new one isn’t working. It will technically connect, but says there’s no internet. However, my phone and other devices have no issue at the same time.

Any other recommendations?

Thanks!
-Kristoffer

Hi Kristoffer :slight_smile:

The fact you can connect to other WiFi acceess points makes it seem like your home router is the issue. :thinking: However you listed everything I can think of to try!
You restarted the router, you forgot the network and reconnected and tried the help documents I posted.

At this point you can wait and see if another Member has another idea to try…or open a ticket and see if Republic can figure it out.

Please come back and let us know how it’s resolved so we can learn for next time :wink:

Could you let us know which router you are trying to connect to, and a rough idea of how it is set up in your environment?
Example: ASUS RT-AC88U | Connected to the ISP provided Modem | No additional routers or Access Points connected
This will give the community a bit more info to try to dig into the problem with you


ETA: While waiting for your update, I came across this article, that provides a couple of things to try

1 Like

Hi Ben,
My router is the following: Orbi Mini Router RBR40
It is connected to the ISP provided Modem
There are no additional routers or Access Points connected.

Thanks for that article. I’m in the process of working through some of the suggestions, but its taking a while because there’s so much I don’t understand. :slight_smile:

Thanks!

Thanks for the help, SuperT.

Still trying to figure it out, but we’ll get it.

Just a quick look at the manual, but here is something to look at for now
Can’t connect to Internet with Orbi? from the Orbi site

Turn off and unplug modem.

  1. Turn off and unplug modem.
  2. Turn off router and computers.
  3. Plug in and turn on modem. Wait 2 minutes for it to connect.
  4. Turn on the router and wait 2 minutes for it connect.
  5. Turn on computers and rest of network.

Hey Ben,
Thanks for the recommendations! (And sorry for my very slow responses!)

It looks like we have a potential solution. During COVID, one of my roommates (who owns the router) has been away and when he came back for a visit, he looked at the settings again and realized that he had accidentally disabled my phone!

I was then able to connect to the internet but shortly afterward it disconnected again. I asked him to try disabling and re-enabling it again and since then it’s worked. So, hopefully that’s the answer.

Thank you to everyone for your patience and help along the way!

-Kristoffer

1 Like

Thanks, makes sense … connected to the WiFi signal, but it was blocked in the router.

Yes sir!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer