Data used without being used?

What phone do you have? G4 Play

What plan are you on? Just switched from 2G to 1G

Does your plan include data, or just talk & text? data


Issue Description

I have created a ticket about this as well. Last month I switched from 2G of data to 1G of data. This morning when the new cycle started it switched plans but shows I already used 1G of data to “Other data”. When I check on my phone data usage though systems it shows that I have used none. Now I have a phone that I can only use on wifi even though I paid for the data.

Hi @jeremiahw!

Have you tried restarting the phone? Have you actually tried to use any data to see if it works?

Yes I tried restarting the phone but it still doesn’t have data service

If you haven’t already done so please open a ticket (https://republicwireless.com/account/tickets/)

I would also try reset the Republic connections by dialing *#*#8647#*#*

2 Likes

You could also try uninstalling and reinstalling the Republic App.

1 Like

This is an issue that will require RW support intervention. Please open a ticket as suggested by @drm186

I have had issues with “Other Data” in the past… so far I haven’t received any coherent explanation from RW about “Other data”… the best I could infer based on my experience was that… it is all the data that the RW app “thinks” was used by the phone but not accounted for by the app. Most common causes of this are system updates on cellular data. This was not the reason in my case…and the “Other Data” usage was only a few tens of MB so did not affect my ability to use my phone for cellular data …which seems to be happening in your case.

2 Likes

Hi @jeremiahw,

There were a handful of lines whose data did not reset overnight, and our engineers are working on correcting this now.

5 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer