December 2021 issue: Data not resetting for new month?

I know there is a current issue adding data. But is anyone on the annual plan having an issue with the month rolling over and their data not resetting?

When I click into the Republic app it shows that I have 31 days left in the month with zero data. When I click on view usage, it shows I’ve only used eight mgs during the current month. However I have no access to data whatsoever.

Hi @kevina.rg60jj,

This is part of the same bug and our engineers are working on it overnight with the hope of a solution tomorrow. I’m sorry for the inconvenience.

Perfect, thank you very much. I was just worried it was a separate issue. I’m happy to know it’s part of the known issue that’s being worked on. Thanks again.

1 Like

13 posts were split to a new topic: One-time data purchase issue 12/14-12/15

My wife apparently got bit by this - started billing cycle saying data was used up - and it never resolved. Now she’s not going to be able to watch our kids swim today :frowning:

I’d be glad to help, but when I look at the service line associated with the account you’ve used to log in here, I don’t see an issue.

Does she have a Help Ticket on the matter?

@benjamins.xdbv9c ,I’ve found her ticket and will be replying to her there.

I am having this same issue. My RW app says that I have 1GB of data left (my full amount, even though I’m 13 days into my data month. It’s not using the data at all, even when I need to when I’m off wifi.

You may want to start with this:

1 Like

Hi @dorothyl,

I’ve made a change on your service line. Please let me know if you’re still unable to use data.

What phone do you have?
Pixel 3a

What plan are you on?
MyChoice + 1 GB

Does your plan include data, or just talk & text?
Includes Data


Issue Description

I noticed sometime within the past week that my phone does not connect to the internet when not in wifi. The connectivity bars at the top right have an exclamation point by them. I am certain this was working on 12/18.

I have tried all the common troubleshooting steps (Restarting phone, making sure data is on, turning data on /off, turning airplane mode on/off, checking APN settings and network settings, resetting network settings, refreshing Republic activation).

This is happening on two(2) phones in my account that are on Android 12. Another phone on Android 11 does not have the issue. My friend with Verizon on Android 12 does not have this issue.

It appears to be an issue between Android 12 and Republic/tmobile, since it is on more than one phone.

Based on the extensive actions you have already taken, I would suggest you Open a Ticket and be sure to add to the request all the things you documented here.

I opened ticket #2201981 yesterday. I posted here from what I put in that ticket looking to see if there is anything else to try to resolve the issue :slightly_smiling_face:

1 Like

ok, the only other thought would be the update somehow hosed the Republic Wireless App.
Try this routine:

Are you sure you have GSM sim cards in both phones? Just wondering if it is a coverage issue rather than Android version issue. Might be worthwhile to double check…since there have been other threads with recent loss of cellular data from members with CDMA Sim cards…as Tmobile continues to shut down and/or replace Sprint coverage.

Good idea. Unfortuantely a reinstall did not correct the issue.

1 Like

Good idea on checking the card type . It is a GSM card.

You have tried a bunch of things already…one thing not on your list was removing SIM, power cycling the phone and re-inserting the SIM… I admit, it sounds hokey… but worth a shot if it gets your going.

I tried the removing and reinserting the SIM. Still no luck. Thanks for the suggestion and nothing is too hokey at this point to try :slight_smile:

1 Like

Hi @waltb,

I’m looking at your account and I think I see the problem, but the problem I’m seeing is not on a phone listed as a Pixel 3a. Would you be comfortable replying (publicly) with just the last 2 digits of the phone number, so I can be sure I’m looking at the correct line? If so, I think I can have this fixed for you in a jiffy.

1 Like