Deep dive into the Macrodroid Macro to overcome Doze Mode based on RW status notifications

I have the same issue. Running latest version. I toggle airplane mode in my home because of a weak cell signal. When I do that, the screen immediately shuts off.

You need to update to 0.9.6 as it provided a fix for the problem reported by @southpaw and ‘fixed’

I am.

Did you change your Display timeout in Android Settings? (as my previous version set it to 15 sec and it remains their until you set back to your desired timeout) …0.9.6 doesn’t mess with the Android setting

Set for 2 minutes. Here’s more:
I turn on airplane mode when I’m home, as I have a weak signal, and it runs down my battery. When I’m leaving, I turn it off. Specifically, I use a macrodroid macro to turn off Bluetooth and location when I toggle airplane mode. Another macro does the opposite when I turn off airplane model

With the doze macro active, toggling airplane mode immediately turns off my display.

As it’s currently triggering off of the RW notification indicating the connectivity state has changed, toggling airplane mode would do it. I’m having to “fight” with mine a bit at times to keep the screen on when the RW notification is showing state changes, too.

I’m curious, @jben what prompted you to build a trigger based on the notification instead of just the timed wake-up, or the timed wake up paired with a specific state? I’m thinking something like… every 50 minutes, if connected to Wi-Fi, then light up the screen, log the action, and turn the screen back off. Was that causing different issues?

1 Like

Per @jben’s post above:
Some devices and later levels of OS have shown to use a different interval of time before Doze turns off the WiFi made it was necessary to take a different approach. This combined with the major improvements in the **[Connectivity Status Notifications ]

The original app (@billp) used the “wait 50” approach.

As written, I can’t use the macro. Maybe if I can find a few minutes…!

  • @southpaw, could you split off the problem that @ceedee is trying to overcome?
  • @ceedee, once the above occurs, could you post screenshots of your two macro in the new discussion?
    • You manually go in/out of Airplane Mode when arriving/departing home … do you also manually turn WiFi back on?

@jben,

I’ve moved this part of the conversation to a new topic. I hope that’s what you meant.

I turn on WiFi manually. The last command is left over from Nougat.

image

Would adding a Constraint for Screen Off help? If the screen is not off, there is not any reason to execute the screen on - off procedure, and it will be awhile before the phone enters Doze Mode again.

I see that this requires the ADB hack for both Location Service off and Device Only … have not gone that way and won’t be able to test.
Feel free to modify my Doze Detect and test with your fixes … but if I add Display Off as a constraint to 0.9.6, how would the second Else If work?

Message an
Expert customer