Diagnostic reports APN settings not present. How to fix on Note 10+?

What is APN settings?

Did I hit on a tough one? I get a message that the required APN settings are not present, when I run the diagnostics in the Republic app… It asks me to reboot to reset the APN. I did reboot but, still the same message.

Hello @whisperpandy

Please see if this helps:

1 Like

I have a new Galaxy Note 10+

From what I can tell, It’s not terribly different.

  1. Go to Settings
  2. Tap Connections
  3. Tap Mobile network
  4. Tap Access Point Names
  5. Tap the three dots in the top right corner :dots:
  6. Tap Reset to default

By the way, if you’re not actually experiencing any issues, there is no need to run the diagnostics and look for things to fix. The purpose of the diagnostics is to, well, diagnose, any issues you are experiencing. Was there a specific problem you were trying to solve?

2 Likes

After I do as you instructed, it narrows the list to 7 choicfs, but none of them are selected.

What are they?

APNO LTE, APN1 LTE, APN2LTE, APN4 LTE REPUBLIC CINET, REPUBLIC SPRINT, REPUBLIC SPRINT The last two are the same.

Okay, and before we select any one of those after resetting to default, was there a specific issue you were trying to solve?

If you’re not having any particular issue, let’s leave it as-is for the evening, and I’ll verify with the engineers tomorrow morning.

1 Like

There are quite a few more Republyc entries if I don’t hit reset to default,

Just trying to get rid of the error message that came up after I removed the GSM sim card and installed the CDMA card that came today.

What was the error message? The same thing about the APN that you found in the diagnostics?

The message read,“The required APN settings are not present, please reboot to reset the APN”.

Okay, I don’t think what I’m asking was clear.

Are you seeing that message as a persistent notification or error “toast” message, or are you only seeing it when you run the diagnostics?

You said it “came up” after you changed SIM cards. Where did it “come up”?

I don’t have a Note 10+ handy, but I just moved a S20+ from GSM to CDMA and I don’t get any kind of error message, although I do see the same “failed” diagnostic if I run the diagnostics test. My understanding (from looking through some engineering documentation while helping you) is that it’s not necessary to manually set the APNs for Samsung phones on CDMA SIM cards, so I think this may be a “false positive” in the diagnostics.

That’s why I’m wondering if you’re seeing a persistent notification of the issue.

When you rebooted, did your phone have access to cellular data?

1 Like

Yes, when I rebooted, the phone came to life on the wifi. I get that fail message after changing to CDMA, and in the diagnostics in the Republic app. The phone was in the automatic mode and I just changed it to CDMA-LTE mode and went back to the APN screen and the one labeledAPN2 LTEIEHRPD internet box was checked. I just tried a wifi call, ok____ I trird a call with wifi turned off, ok---- and lastly , I accessed the internet on wifi, and again, ok.

When you installed the CDMA SIM card, a tool on the phone called the Sprint OMA-DM client is supposed to handle the activation on Sprint’s network and configure the APN. “Automatic” is the preferred mode.

Since you’ve changed a few things, you’ll want to make sure you can send MMS on cell, and access data on cell.

1 Like

I can go back to automatic, but then, none of the APN bixes are checked

Right. I think that’s how it is intended to be. We don’t need to manually select APNs because the Sprint OM-DM client handles the necessary programming.

Go ahead and set it back to automatic, and if you have any issues with MMS or cellular data access, or if you have a persistent error message when you do not run the diagnostics, then follow up in your help ticket so the team who sent you the SIM card can troubleshoot with you. I’ve added some notes to that existing ticket so they’ll have the gist of tonight’s conversation in front of them.

1 Like

Everything seems to be working fine except for that error message in the Republic app… Incidentally, is VoLTE supposed to be turned on?and, on the settings page that has wifi and wifi calling, is the wifi calling supposed to be turned on?

VoLTE and WiFi calling do not need to be turned on.

The only thing you need to manually make sure to configure is to enable cellular data and roaming for both calls and data.

Message an
Expert customer