Does the phone ringer "go to sleep"?

I just finished a 48 hour on call shift.

Last night I had 2 calls that the phone never rang so they were missed.

About 45 minutes later I received another call that rang.

Not being able to have the phone ring when on call isn’t a good thing.

I was on wifi about 12’ from my router.

The phone was laying arms length from me.

I had dozed off and am pretty sure I didn’t sleep through the ring.

This is a new Moto G4 play but happened with my previous phone.

I guess my question is does the phone go inactive in some manner after a period when it hasn’t had any movement?

If so, how do I change that setting?

1 Like

Make sure that under

Settings -> WiFi -> Advanced WiFi -> “Keep WiFi on during sleep” is set to “Always”

There is a lengthy discussion about how sometimes phone continues to sleep even with this setting.

Is your phone losing its WiFi connection while sleeping?

1 Like

Thanks for that info.

Checked and it is set on “Always”

Will look at the link you provided

Check to see if you have a downtime defined in the settings

setting/Sounds and notifications/interruptions–>downtime

it may also have a sleep/meeting quiet setting in the Moto App

1 Like

Thanks for your response.

I didn’t have an “interruptions” option in my settings and didn’t have that in my Moto app either

Some users are still experiencing a problem with the phone not waking up when a call comes in. This is discussed in Is your phone losing its WiFi connection while sleeping? as mentioned by @amitl above.

  • Some users have found that having the phone plugged in (charging) eliminates the problem (this works for me)
  • Others have resorted to using the MacroDroid and running a wake-up program as outlined in the above link
  • Republic has made adjustments to the App that have partially overcome the problems, but users are still reporting problems depending on the quality of the cell/wifi connection.
1 Like

Do you have cell coverage or is WiFi the only option? We try WiFi and if it cannot answer then we move to cell. Cell is a backup but if that is not available then we only have one path.

I have poor cell coverage at my house, seanr.

I had just full charged the phone prior to moving the phone to it’s resting place by me, jben.

My understanding is that the Android code does not shutdown WiFi at all during charging (and I have never had a test call failure while on the charger)

Reference states

When the user plugs the device into a power supply, the system releases apps from the standby state, allowing them to freely access the network and to execute any pending jobs and syncs. If the device is idle for long periods of time, the system allows idle apps network access around once a day

I have been unclear, jben.

The phone had been charged and removed from the charger when this happened.

It nay have been inactive for more than an hour

Yes, I understand … however the Android reference I provided and my own experience indicates that (in my case anyway) the phone will go into a hibernate state after a period of idle time (usually ~1 hour) … user feedback indicates that depending on cell/WiFi coverage the phone call may do any of the following: go to voicemail, establish the call on cell, establish the call on WiFi

The Android hibernate state does not occur while the phone is on the charger (which is where many of us leave it at night to ensure no calls are lost)

Most times I don’t care if it works but in those critical times that I need to be available, it’s an inconvenience.

I don’t, typically, move my charger around but may have to

Exactly the same thing happens with my Moto G4 Play. I have full strength WiFi, full strength cell signal, and other settings are correct. Even with Macrodroid app installed, my phone still doesn’t ring sometimes. I do not get any missed call notifications. I have contacted the RW tech support with no resolution. I am thinking of just switching to some other provider even though I like RW service.

Based on your description, your issue is different than this post references. While some components are similar, what is causing your issue is probably very different. If the phone doesn’t ring we automatically forward to cell. When we forward to cell we literally call the phone on its cellular number just like any other carrier. The only time we would not forward the call is if the phone tells us it is ringing and that the user did not answer it.

I will take a look at your ticket, but from the symptoms it doesn’t sound like the same issue. What do users who call experience when your phone doesn’t ring, do they just go to voicemail? Do they get a fast busy or a network error? Is the call even getting to Republic?

Thank you for replying. People that call me get sent straight to Voicemail. If they do not leave a VM, I would not get a notification. I have noticed that sometimes when my phone doesn’t ring, I have full WiFi signal and full cellular strength but the Republic arch is empty inside and the status says “Talk and Text via cellular, wifi data”. When I toggle WiFi on and off in the Settings, the RW arch becomes full.

I had similar issues with my previous phone, a Moto E 1st gen. But in that case when the phone didn’t ring at least I would get a missed called notification.

I have a Moto G4 Play with Amazon Prime.

I have been a RW customer for a couple years and since day 1 I have had this exact problem with 3 different phones. I tried everything to fix this problem over the years and NOTHING WORKED. This is my last month with this company…I have simply had enough. I don’t think it’s asking too much for a cell phone to RING when someone calls. Good riddance RW!!!

See my “Good Riddance” comment. You will never get this fixed…good luck and I hope you don’t end up as frustrated as I was with this service. It’s not ready for prime time…

1 Like
Message an
Expert customer