DriveFi is now available the Google Play Store


#21

I believe I only uninstalled the DriveFI app, the autolocation plugin is still there (I’ll check for sure). I’m always running low on memory, but am definitely above the 40MB alert limit. (aside): that wouldn’t be an issue if there was more internal storage on the phone :wink:

I can reinstall and let you know how things go. I don’t really know if it was on the card or internal - I have the developer code enabled to auto-install everything to the card, so it may have been installed there…


#22

Amended: I also uninstalled the autolocate app. I will put it back on right now and see if the behavior returns. If not, I’ll put the drivefi app back and let you know.


#23

OK, it looks like DriveFI sets a lot of the autolocation settings, so have installed the whole thing again. My free memory is 62MB. I do see that autolocation appears to be installed on the card - probably an issue.

DriveFi appears to be internal and doesn’t give the option to move to card.


#24

good stuff - thanks for doing this. i wonder whether autolocation needs to be on internal storage or not?

mine is on internal and does NOT give the option to move to sd, so i’m guessing it is SUPPOSED to be on internal anyway… but often that doesn’t really matter.

DriveFi does set the configuration of autolocation - but it doesn’t have to do so to a clean install of autolocation. DriveFi reapplies the settings each time the background service starts up (should be once per reboot, but possibly more often if you use a task killer, etc). i’ll check, but i don’t think enabling/disabling the service would actually trigger the config function for autolocation (it is handled automatically as part of the ‘context’ settings from Tasker - in other words it is beyond the scope of my own code and is performed by the framework I used to write the app).

if you see the issue again, it would be very interesting to also test:

  • does it remain an issue after a reboot?

  • what about if you move autolocation to internal storage? (perhaps requiring a reboot as well)

  • what if you uninstall DriveFi but start autolocation manually?

thanks,

-bit


#25

I think it did still have the issue after a reboot, as that is the standard first step for anything like that.

So far, this afternoon has been good and the program seemed to work well on a short trip. I did move autolocation to internal memory. If I’m bored sometime, I might move it back to see if that is indeed the issue, but for now I’m happy to have everything working well. Thanks for your feedback and for a great add-on for the community!


#26

that’s great news that it’s working well for you now! thanks for putting the work into testing things - always good to get feedback (even bug reports, in fact sometimes ESPECIALLY bug reports!)

do let me know if/when you try moving autolocation back to the sdcard and whether the issue recurs then. i do hope to write my own (free) plugin to replace autolocation, but that project is on the back burner just now. when i do get some free time to put into that project i’ll be sure to keep this potential issue in mind.

-bit


#27

Installed DriveFi. Also purchased the donation “app”. You deserve it.

My comments:

  1. Did detect I was driving when I left the house. Yeah!
  2. Said I wasn’t driving when I got to my second stop light (very long stoplights here… sat for about a minute and half at a couple of them).
  3. Never went back to saying I was driving after going out of driving mode at that stop light… even after I was driving for 3 minutes (30 to 40 mph). I think my phone started latching unto all the stores near me with WiFi, so never managed to trigger the “not on WiFi” rule to start the driving detection routine.

So I think it is well on track to working for me. Perhaps add an option for how many 30 second loops you need 50% confidence for both going INTO and OUT OF driving mode. I like the existing detection of I’m IN driving mode, but would like it to take longer before deciding I’m not driving anymore.

Thanks a bunch!


#28

nice - thanks for the feedback @ellingson (and for the donation too!)

i think you’ve got a good idea here; perhaps give the user the option to set X ‘driving’ events detected in a row or Y ‘not driving’ events detected in a row before triggering the mode switch. it gets a little sticky though, because of the way AutoLocation was designed and how Tasker normally operates. i can’t always depend on AutoLocation actually triggering multiple back-to-back events of the same type; if you enter driving mode and stay ‘driving’ AutoLocation MIGHT send me more event notices, and it might not.

Perhaps I could monitor the name of the wifi access point and only postpone driving-mode if you remain connected to the SAME access point? that way if your phone connects to some wifi when driving, it should switch to some other wifi shortly and at that point DriveFi could force the wifi off and enter driving mode.

what do you think - would that work for you?

-bit


#29

Thank you for writing this app. I’ve been using it for a few weeks and it works great. In addition to preventing the obvious problem with connecting fleetingly to wi-fi networks while driving, it solved another problem for me. I use endomondo sports tracker to track mileage on my bike rides and endomondo would stop tracking my mileage when the phone tried to connect to wi-fi. I’ve not had this issue since I installed DriveFi.


#30

@masil - that’s great - an unintended but serendipitous side effect!

thanks for the feedback!


#31

The third party app developer is pretty shady. You can buy it for $1.29 or do the free 7 day trial, but the 7 day trial automatically signs you up for a monthly .99 subscription. I have to decide if I want to try this or not.

Maybe I can ask here: I ride the bus to and from work and I find I have lots of connection issues because of all the access points along the route. Will this disable my wifi while riding the bus, but enable it at work and home?


#32

Yes, it should work fine to disable wifi while on the bus. I use it while biking and it works great to block unintentional connections to wifi. Interesting about the monthly .99 subscription for autolocation-guess I just bought it right away for $1.29.


#33

@bitflung, will this Smart WiFi Toggler work to take the place of the paid AutoLocater app? It’s free today on Android Giveaway of the Day…

Smart WiFi Toggler - Android Apps on Google Play


#34

I’m new to WR, and just downloaded DriveFi and Autolocation. Is is necessary to purchase the unlock key for the latter in order for it to work with DriveFi?

TIA~
Dida


#35

yes, you’ll need to unlock the autolocation app in order for it to work properly with DriveFi.
it’s been a while so the pricing may have changed, but back when I wrote DriveFi the autolocation app was $1.29 to purchase.


#36

Thanks so much for the confirmation. And FYI, Autolocation is 99 cents now.


#37

Thanks for the heads up on this app. I DL’d it but when I launch it I gt a notice that it requires the AutoLocation Activities plugin. I tell it to get it but nothing happens, and the wifi app doesn’t open.

Any suggestions?


#38

I’m not sure why the prompt to install autolocation failed for you, but you can manually install it by opening this link:

@didak.qblqpl says the current price for the full version is $0.99 now; glad to hear it’s still cheap :slight_smile:

-bit


#39

I’m good-- I had already installed it.
Dida


#40

So to run this app we need:
Tasker (by Crafty Apps $2.99)
Autolocation (by Joaomgcd unlocked for $0.99)
DriveFI (by Bitworks with optional donation)

I have noticed my phone trying to connect frequently while stopped to xfinitywifi (and others).
This would be nice to stop that.
Sometimes I do connect to a Karma GO device in my car, so can I disable it too?
Thanks!