DTMF Touch Tones not working Moto X and Nexus 5x

I’ve been trying to contact a company that requires me to press 2 after the call connects, and on the Nexus 5x running 7.1.1 it never registers the press. I tried with a Moto X 1st Gen on Republic as well and same issue. I tried it from both Wifi and Cell. I thought maybe it was only this number, but calling from Google Voice on my laptop registered just fine.

I had another number today that I called and needed to enter a 4 digit extension and after pressing it, it told me I did not make a valid selection. I only tried it from the 5X so far. With two numbers, I’m more leaning towards a Republic/phone issue

I also noted that if my contact has commas and the extension, that has worked with other phones I’ve used, I get a popup from Republic saying “Dialed number not allowed”

Any ideas? I don’t see a Settings>Calls and in the Dialer, I found settings, but don’t see anything for DTMF

1 Like

Hi @dana,

What you are experiencing isn’t all that unusual for Voice over Internet Protocol (VoIP) calling. VoIP is the technology powering Republic’s WiFi calling. It is curious that you also mention this happening when on cell. It’s further curious that Google Voice works as that’s VoIP, though it uses different transport protocols than Republic (XMPP vs. SIP).

I don’t have a Nexus 5X to test with, so am uncertain where to direct you for settings changes. On my Moto X Pure (which runs more or less stock Android), I would try the following:

  1. Open the Dialer (Phone app).
  2. Tap three stacked dots upper right.
  3. Tap Settings.
  4. Tap Sounds and vibration.
  5. Verify Dialpad tones are on and that Dialpad tone length is set to Long.

Perhaps that’s close enough to help you find something similar on your Nexus 5X? Beyond that, you might try waiting a second between key presses and/or muting your phone’s microphone when entering DTMF tones.

Regarding the inability to dial numbers with waits and pauses (commas and extensions); this is a known limitation of Republic’s blended WiFi/cell service.

1 Like

Under Sounds and Vibration, I only have a checkbox for “Keypad tones”, no option to set them as Long.

The comma thing is pretty annoying, as all of my previous phones supported that so I have several contacts with them in the number. If Republic would just ignore the comma and anything after that would be better than not letting me make the call at all because they exist.

Message an
Expert customer