E-mail & Text not delivered on cell network

What phone do you have? Samsung A51

What plan are you on? 1GB data

Does your plan include data, or just talk & text? data, talk, text


Issue Description

I have a Samsung A51 phone. If I am on a cell phone network, my text and emails are frequently delayed until I get on a wireless network. Example, last night when I returned home and connected to my wireless network, 5 emails and 4 text messages showed up. These messages had been sent up to 4 hours earlier. This has been happening frequently over the last few months.

Hi @jimg.tk2mpg,

Please make sure you have the phone configured to use cellular data:

If everything is set up correctly, we may need to try to determine whether there was adequate cellular coverage in the area where your text messages and e-mail messages were not delivered.

1 Like

All the Basic Network Settings are correct.

1 Like

Thanks, @jimg.tk2mpg,

Because you mentioned e-mail, it really sounds like a matter of cellular data connectivity, either somewhere in the phone’s configuration, somehow due to the phone needing to reconnect to a tower, or because coverage was inadequate at your location. I say that because Republic Wireless is in no way between your e-mail server and your phone. If you had seen this with only text message delivery we would need to look more closely at whether there was anything on our network causing this delay, but your e-mail does not pass through our servers, so that is a really good clue (and great observation) that your phone was somehow not able to connect to cellular data.

Still trying to understand why I frequently have delays in receiving text or emails over cellular. Looking over my Android 11 settings, I have Data Usage / Data Saver is currently set to ON. Is this correct? Samsung A51

I don’t have an A51 to check, but when I looked at my Samsung Note 20 Ultra, I found by drilling down that I had not allowed Google Messages to use Data when Data Saver was on.
I find that using the Search within Settings is the easiest way to find things. I didn’t have Data Saver turned on which is why I did not experience the problem.

1 Like
Message an
Expert customer