Email as a text message

What phone do you have? Galaxy J7

What plan are you on?

Does your plan include data, or just talk & text? Data


Issue Description

I would like to email a text message to my phone. I use my number@text.republicwireless.com but, I don’t receive the message.

This is the first time I have tried to do this.

Hi @garys6 - Have you checked the following setting in the RW app?

  1. Open Republic Wireless App
  2. Tap the gear for settings in the top right of the screen
  3. Tap Advanced settings
  4. Find Allow SMS messages from email and confirm that it is checked

Hope this helps!

3 Likes



I will note I never had luck getting text to SMS to work from an exchange server, also simple text format works best (not HTTP format

There is no Advanced Settings option on my phone. I see Advanced Features but no Allow SMS option.

I think you’re looking at the setting of the phone by mistake and not the Republic Wireless app.

3 Likes

Thanks! That was the problem!
Its working now.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer