"Enable handover on networks" disabled on Android Q 10.0"

What phone do you have?
Google Pixel 4XL (Android 10)

What plan are you on?
MyChoice

Does your plan include data, or just talk & text?
Includes data


Issue Description

My house has strong wifi but poor cell reception, and for several years I’ve used the “Enable handover on networks” setting in the RW app’s Advanced Settings to disable handover on my network to avoid poor audio quality during calls.

I just got a Google Pixel 4XL and while it successfully activated and works for calls and texts over both wifi and cell, the “Enable handover on networks” option is disabled/grayed out. During a phone call I just had, the phone handed over to cell multiple times, resulting in poor audio quality for the remote party. I enabled “Allow manual handover” and manually handed over to Wifi each time (which worked immediately and restored the call quality).

Are others with this phone able to use “Enable handover on networks”? I’m hoping this is resolvable (not some compatibility issue w/ the device), because the phone won’t be very usable for calls in this state.

@rationull,
AFIK, this appears to be a previously un-reported condition.

  • If I may suggest, would you Open a Ticket to ensure that this condition can be addressed by Republics Help Team
  • Your write up clearly defines the problem and the traditional information you gathered by manually handover to restore call quality would be interesting.

Hi @rationull,

Android Q has a new set of security rules that prevent our app from accessing the list of known networks. Our engineers are aware of this issue and opted to gray out the setting as they try to think through a workaround.

We do have a master ticket for the issue, if you’d like to simply report that this is a setting you depend on, and that you need it restored, please ask that your ticket be attached to master ticket 1830710.


Pinging @Ambassadors for situational awareness.

5 Likes

Thanks @jben and @southpaw!

I will open a ticket as described. I will likely suggest that if this is going to take some time to figure out, that a blanket “disable automatic handover” option might be useful (although I’m not sure this is something RW would want to implement, I vaguely recall that it’s come up in discussion before).

2 Likes

@southpaw FYI my ticket number is 1867258, asked to get it attached to the master ticket.

Thanks!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer