Failover to 3G for voice calls every time?


#1

Is there a way I can setup my phone (using the X Pure) to taking incoming calls when I’m on WiFi and automatically/automagically fail the call over to 3G cell network instead of utilizing the WiFi? I don’t know what the deal is where I work but my phone will ring but often times I can’t hear/talk to the caller when I pickup on WiFi.


#2

Go to the republic app>the gear on the top> advanced settings>enable handover on networks> uncheck the network you don’t want to handover to WiFi.

You can also enable the allow manual handover option so you can switch it when you want through a notification.


#3

That will ensure the call stays on Wi-Fi and doesn’t hand over to cellular. I think that’s the opposite of what the original poster had in mind. The most practical way to keep a call off of Wi-Fi is to not connect to Wi-Fi.


#4

My bad. What that option does I believe is, if a network is checked it means that it will automatically enable handover to that network. If you uncheck one it will not automatically connect. Since Republic does not have its own rom anymore I don’t think you can force it one way or another.

You could still leave the WiFi on enable the “allow manual handover” option. Then when connected to a network with poor WiFi calling you can just hand it over to cell using the notification.


#5

Thanks guys. The manual handover option looks like the one I’ll be using. If this is my last comment it must’ve worked.

Edit: Well, it kind of works. Pulling down the notifications window isn’t ideal. Having input my security pattern totally sucks when you’re in the middle of a call but I can live with it.


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.