Feature request: Automatic cell radio shut off on specific wifi networks


#1

Is there a possibility for the option to automatically shut off the cell radio when connected to user chosen wifi networks to be added into the republic app? At my home I have just enough cell signal pop up from time to time for it to pick up calls (or try to make them) and then promptly drop them before anything can be done; this intermittent signal is also no great for my battery life. Obviously it seems there may be some difficulty in this as the app store is not chock full of apps to do it already, but if possible it certainly would be an immensly useful feature.


#2

In the latest version of Android it is not possible for an app to disable the cell radio without root. Because of this, it isn’t possible for Republic to add this to their app (and also why you won’t find apps on the app store that can do this).


#3

@donaldl.rwz1os @louise states android does not allow this and for Republic to make this happen they would not only need a custom ROM) but one that is not link to Google services (like the Amazon Fire line) (which Republic is not going to as there a reason they did not release the OS for the Legacy Moto Phones and got fully out of the ROM in 3.0 phones

Google took the ability to control the Cell antenna a few OS version ago (I want to say Jelly Bean 4.2) they then removed the airplane setting control in Kit-Kit (4.4)
they did this as a security issue (stopping wayward apps from overriding the user setting and eating cell data anyway)


#4

Oh, well bummer and nevermind then. Thank you for the explanations!


#5

I occasionally have this problem, and what I do is go into the Airplane Mode and then turn Wi-Fi back on. Seems to work.


#6

I made an app a while back (yikes, it’s been 3 years now!?) to help with this. it’s free and on the google play store: https://play.google.com/store/apps/details?id=com.bitworksapps.wifly

As others stated, google made changes which prevent apps from turning the cell radio on or off for you. Due to those changes you have a process to follow if you want to manually do what you were asking for in this thread:

  1. wait until you are connected to a relevant wifi network (where cell radio could be turned off)
  2. manually turn on airplane mode
  3. manually turn wifi (and bluetooth?) back on
  4. wait until you aren’t on that wifi network anymore
  5. manually turn airplane mode off
  6. grumble aloud when you realize that you forgot to turn airplane mode off when you left home and you’ve been offline all day, missing calls and texts

aside from the obvious issue that you’re manually doing lots of stuff here, there is an additional issue that you might forget to turn airplane mode off (re-enabling the cell radio). this means if leave the wifi coverage area without remembering to turn airplane mode off all your incoming calls, texts, etc won’t work, because you’re offline!

My app was meant to help with this. The idea is that you will have to manually turn airplane mode ON when you are on the relevant wifi network(s), but it would automatically enable wifi (and bluetooth if you want) for you. it would also remind you to turn airplane mode off when you leave the wifi coverage area. with this app the above 6 steps becomes:

  1. wait until you are connected to a relevant wifi network (where cell radio could be turned off)
  2. manually turn on airplane mode (wifi and/or bluetooth will be re-enabled for you by the app)
  3. wait until you aren’t on that wifi network anymore
  4. manually turn airplane mode off
  5. wonder why your phone keeps notifying you of something; check it; see that it is complaining that you should turn airplane mode off now that you aren’t on wifi anymore; be happy that you’re back online with very little downtime

that’s the intent anyway. I haven’t touched the app since Dec 2013, so i can’t say for sure how well it works these days. give it a shot and let me/us know whether you find it useful!


#7

@bitflung I was going to mention your app earlier, but it felt a bit like saying “Beatlejuice”


#8

you gotta say it three times in a row for the magic to happen :wink:


#9

@bitflung
It just doesn’t look right see you post without the shield next to your avatar


#10

i admit it feels a little bit naked - but then again it also feels weird that i STILL haven’t updated my avatar here to that awesome super-baby picture from the old forums. that’s a pretty telling lapse: i’ve been absent so long now that the shield really didn’t’ fit anymore. everything ends eventually.

posting now feels sort of nostalgic, reminds me of long ago BEFORE i was an ambassador. trying to put a date on that makes my head spin and now i feel old :slight_smile:

retiring from the ambassador program actually spurred me into action here (at least i think that’s what got me over the hump and back in the saddle, plus some other cliches i can’t recall just now).


#11

Thank you for the app link! however alas, it seems to not work on Moto g4 play.
And your description of how the manual way of accomplishing the “Wifi but no cell” is extremely accurate.

Maybe instead of shutting down the cell radio, a feature could be added to just force calls to only be made or received via wifi on specified networks, without turning off the cell radio? Is that anymore feasible? As may be obvious, my knowledge is limited, and I am not sure how I would even query google about such a thing.


#12

Not fully what your asking for but there is a way to prevent a hand off to cell one selected networks
in the Republic app in advance setting one can turn off enable handover to cell


#13

Are you sure it didn’t work? I just fired it up on my Moto Z Play and it seems to work properly. I didn’t get to test the pester feature but I can test that tomorrow.


#14

Maybe I am doing it wrong then? I installed the app, and selected wifi on, bluetooth off, notify set to notify+beep, and pester to 2 minutes, but wifi does not automatically come back on when airplane mode is activated, (and I have no way to tell if wifly is still active, as it seems to disappear as soon as I return to the home screen)

Tried it with nova launcher and stock launcher and it does not seem to work either way.

Am I just suffering from some minor block headedness?


#15

Thank you! However the problem is not that it hands off, but that if it smells a whiff of cell signal, it wont call out over wifi, it just keeps trying to send the call over cell and hanging at the dialing screen or dropping it after a second or two. The same problem will happen with incoming calls. This makes it so that sometimes if you need to receive or make an urgent call you have to do the airplane mode trick to force it to Wifi.


#16

This indicates that there is something about the wifi network that the phone doesn’t like. It prefers wifi. When it doesn’t, it means that some parameter of the network (jitter, latency, etc) is triggering the phone to think that wifi is going to be an issue and therefore to force the phone over to cell. You should be able to see this when you look at the Republic Status message which will say something like “Cell Talk & Text, Wifi Data”


#17

Ahhh, ok. In our case the phone is usually displaying the green “all good” bar when we run into this. So far, forcing it to wifi always results in a stable call (sometimes sound quality is a little flat, but there is no breaking up, and that is all I care about) , and I am familiar with the blue conncetion problem/ cell signal bar. Can it be a scenario where whatever hiccup in the wifi is cycling quick enough not to trigger the notification change, but still affect the call? Or is there a set degraded conncetion quality at which the phone tries for cell? (Even though in my scenario a wifi call, while the audio suffers a bit, is still stable)
By no means do I believe my wifi network is infallible, but often having the green bar during these times is what has thrown me off.

And to clarify (because I feel like I can come off as blunt in my writing); I am in no way feeling contentious or malcontent towards republic, just curious and looking for answers and solutions.


#18

Maybe I am doing it wrong then? I installed the app, and selected wifi on, bluetooth off, notify set to notify+beep, and pester to 2 minutes

btw: you don’t’ need to set bluetooth to “off” unless you want it FORCED to be off all the time. you can leave it to “—” and the app won’t change the bluetooth settings.

but wifi does not automatically come back on when airplane mode is activated,

interesting. it works for me here on the Moto Z Play, which is running Android Nougat. it looks like your G4 Play is running either Marshmallow or Nougat - so it should behave the same as my phone.

(and I have no way to tell if wifly is still active, as it seems to disappear as soon as I return to the home screen)

yeah, i didn’t give much by the way of user feedback in the app. sorry.

Tried it with nova launcher and stock launcher and it does not seem to work either way.

your choice of launcher shouldn’t matter.

Am I just suffering from some minor block headedness?

i’m not sure. let’s try walking through the flow:

  1. launch the WiFly app
  2. select:
    WiFi: On
    Bluetooth: —
    Notify: Notify + Beep
    Pester: 15 sec
  3. tap the BACK button (bottom of the screen, the left facing triangle/arrow thing)
  4. swipe down the notification shade twice, tap the airplane mode icon
  5. wait about 3 seconds
  6. wifi should turn on automatically by now
  7. turn off wifi manually (to test the pester service)
  8. after about 15 seconds you should get a notification (including a beep at the volume set in system settings for notifications) that WiFi is not connected and reminding you to disable airplane mode
  9. tap the notification and it will take you straight to the system settings page where you can disable airplane mode
  10. after disabling airplane mode WiFly should automatically turn wifi back on (it was disabled manually so turning off airplane mode wouldn’t normally do it)
  11. now that you’re back on wifi, WiFly will pester you every 15 seconds to turn ON airplane mode; you can make WiFly quite again by tapping the dismiss button in the notification

i just did all of the above, exactly as listed, on my Moto Z Play. I can record the screen as i do it maybe… would that be useful?


#19

ok, it seems that the app is a little flaky for me in one regard:

  1. wifi and cell connected; wifly is setup to turn wifi on when airplane mode toggles
  2. app tells me to turn on airplane mode (because i’m connected to wifi)
  3. i turn on airplane mode
  4. once in airplane mode wifly correctly enables wifi for me
  5. i MANUALLY turn off wifi
  6. wifly detects that’ wifi isn’t connected anymore; triggers a notification to disable airplane mode
  7. i turn off airplane mode
  8. wifly does NOT reliably turn wifi back on for me here. it was MANUALLY disabled, so toggling airplane mode won’t normally turn it back on - and i THOUGHT wifly was going to turn it on for me… i even thought it did just that in my prior test… but i couldn’t reproduce this feature. so if you MANUALLY disable wifi you should expect that you’ll have to MANUALLY enable it again

video walk-thru is available here: wifly-walk-thru
no audio, aside from the notifications beeping - i’m at work so couldn’t talk through it.
note: towards the end when i draw on the screen, i’m showing that tapping the ‘dismiss’ button in the notification stops the pestering notifications which otherwise trigger once every 15 seconds.

-bit


#20

Ooh, ok, so it is running, as it pesters me as it should, but it still doesn’t automatically turn on wifi.
However just the pester feature will at least keep me from forgetting to re-enable cell, which unless a more integrated solution ever appears, is at least a great start, as an extra tap to turn wifi back on will not kill me :grin:
Thanks for pointing out your app, and for having madebit in the first place.