Fix Google Pixel REG09 E911 Error Message

For some reason the latest update to the Pixel 3 and Pixel 3a (and their XL variants) has caused the OS to try and toggle on the OS wifi calling, which doesn’t work with Republic. As you may know Republic has its own wifi calling and doesn’t use the OS version. When this happens the phone throws multiple errors. To fix this, go to Settings – Network & Internet – Mobile Network – Advanced – Wifi calling and toggle it off. That will fix the errors and will not impact your ability to make wifi calls

If the option isn’t present on your phone, then unfortunately only a network settings reset will fix the issue.
Before you take this next step, please note it deletes all Bluetooth and wifi connections, as well as resetting the cellular connection.

Go to Settings > System > Advanced > Reset Options > Reset Wi-Fi, mobile & Bluetooth
Read the warning, tap “Reset settings.” You will be warned a second time. Tap “Reset settings” to confirm. The process will usually take 5-10 seconds and the cellular signal bars icon will go away for a moment. Once the cell signal bars icon returns, you should reboot the phone.

3 Likes

I have a Pixel 3 with the latest (June) update installed, but I don’t have the WiFi Calling toggle setting in Settings -> Network and Internet -> Mobile Network -> Advanced. Where else might I find this?

Are you getting a wifi calling error message?

No. I was trying to be proactive.

Nothing to be proactive about. This only applies in the specific situation where the update causes the error to appear.

OK. Thank you.

1 Like

I activated my Pixel 3a XL yesterday. I am getting these errors but do not have ‘Wifi calling’ in Advanced settings. What can I do to fix?

Everything seems to be working fine otherwise - just keep getting the REG09 error notifications.

Thanks!

If you open the dialer, hit the three dots on the top right then select Calls, do you see a toggle there?

No.

When I go into ‘Additional settings’, it immediately triggers the error and hangs for a while trying to read settings.

Please try this: Go to Settings – Apps & Notifications - Click “See all xxx Apps” and then scroll down to Phone. Click it and then click Storage and then Click “Clear Storage”. Ignore the doomsday warnings and allow the data to be cleared. When it is, please restart the phone. Has the error stopped now?

That seems to have worked. I haven’t received the error and can go into those menus without errors now.
Thanks!

Great! To try and track down the source of what was going on, what carrier was the phone on before it was moved to Republic?

None - a brand new Pixel 3a XL purchased from Amazon Prime Day. I put the new Republic SIM card in before powering on the phone for the first time. Maybe I shouldn’t have done that?

When prompted to bring over data from my old phone during the Google Account setup, I declined. No apps or data were brought over from my old phone (Moto Z).

There was one security update and a bunch of app updates, including an update for the Phone app. I installed the Republic app during that time as well.

I activated (transferred my number) to the new phone after those updates.

Hmm… OK thanks. It’s possible that the phone originally interpreted the SIM as a T-Mobile SIM and tried to activate their wifi calling, and then once activated with Republic removed the option, because it isn’t used with Republic. That said, the logic on the phone should cause the option to turn off and then disappear, rather than just turn off.

If I get a chance, I’ll see if I can replicate what you saw and then Republic can open a bug ticket with Google.

That sounds plausible. When searching settings, “Wi-Fi calling” shows up as a menu option, but selecting it dumps me into the “Mobile network” screen with no option for “Wi-Fi calling”. This seems like it is by design (once Republic activation occurs) so RW customers don’t accidentally enable it.

Can the Republic app force Wi-Fi calling off before hiding/removing the option during activation? Not sure how those things work.

It seems like the sequence was:

  1. Wi-Fi calling enabled (not sure how)
  2. Wi-Fi calling option hidden (during Republic activation)
  3. Phone stuck in error-ed state until clearing storage (which I assume resets Wi-Fi calling to disabled)

I got the error again.

I Powered off the phone (to install a screen protector) and when I started it several minutes later, I received the error again.

I went through the steps that fixed it before, and the error is gone again.

“Power off” behaves differently than a “Restart”. It must put the incorrect configuration back and clearing the Phone app storage will be necessary after every Power off.

Sheesh, it really shouldn’t. Can you try this? Power off the phone. Remove the SIM card. Restart the phone. Connect to wifi. With the phone connected to wifi, but no SIM in the phone. are the Wifi calling options present?

No, I don’t see any:

Interestingly, when I replaced the SIM card while it was powered on, I didn’t receive the REG09 error.
When I go into the Phone app Call settings -> Additional settings, I can force the error. When I did that after replacing the SIM, I didn’t get the REG09 error, but I got the following Network or SIM card error:

I powered it off/on again to test - and the REG09 error returned and the Network or SIM card error was also there.

Clearing storage of the Phone app still works to remove REG09 error and the Network or SIM card error.

Before you take this next step, please note it deletes all Bluetooth and wifi connections, as well as resetting the cellular connection. If you don’t want to delete the Bluetooth and wifi, then don’t take this step. This is the last thing I can think of trying to get rid of it for good.

Please try the following steps to resolve this issue:

Go to Settings > System > Advanced > Reset Options > Reset Wi-Fi, mobile & Bluetooth
Read the warning, tap “Reset settings.” You will be warned a second time. Tap “Reset settings” to confirm. The process will usually take 5-10 seconds and the cellular signal bars icon will go away for a moment. Once the cell signal bars icon returns, you should reboot the phone.

That seems to have worked! After restarting, no errors. I then powered off & on - still no errors!

Thanks for all the effort. I truly appreciate your help.

1 Like
Message an
Expert customer