Frustrated - Thinking of going elsewhere

billing

#23
  1. unlike other 3rd party apps (and the ASOP Messaging or Google Messenger/android messages) the Republic anywhere is fully controlled be Republic so it is easier for Republic to debug issues as it controls the code
  2. with Republic anywhere there is a archive stored on the Republic servers even after the message is sent (this is not true before anywhere is is installed on your phone)

#24

So once I load Anywhere, RW has and retains all text messages that I send/receive? That doesn’t sound like something that I want…


#25

So I was asked by support to do:
Please follow the steps below to update your phone’s cellular settings:

First, please make sure the phone is connected to WiFi with a solid arc.
From the phone, please dial ## 72786# and follow the directions on the screen. Once the phone has rebooted, it should guide you through the hands-free activation.
Once that is completed, be sure to do a Profile Update over WiFi.

Now the phone rebooted and is just at a screen that says ‘Cellular Activating’. How long should it sit here? I haven’t even gotten to the ‘profile update’ portion yet.


#26

I did resolve the issue with activation. Was related to my network at home.

Figured I"d update everyone that Republic Anywhere did not resolve the issue. Below is some of what I sent to support though I"ll not post the images I"m referring to.

name missed several texts in a group MMS today between 2 AT&T users and herself. I’ve attached screenshots from Republic Anywhere on my computer.
I’ve asked her sister to screenshot the

Comparing Image AT&T 1 and Republic 1:
name misses 4 messages before she receives anything
name misses 2 messages after the ‘Princess doesn’t…’ text
(I think the person who sent me the AT&T screen shot missed capturing the ‘yes’ text)

Comparing Image AT&T 2 and Republic 1:
name receives the 'I don’t math on my day off’
name doesn’t receive the ‘As usual name doesn’t get texts lol’. (Here you can see that this is a longstanding issue that our families are aware of).

Thoughts?

As I understand Republic Anywhere, the servers are caching the messages for distribution so if there’s missed data, the server itself never received it?


#27

MMS is not a guaranteed service, carrier to carrier, so we have seen some carriers drop messages before they even get to our network. It is so hard for us to tell when this happens, kind of an absence of a flaw issue. Group MMS can be even worse. We look in our servers and see nothing out of the ordinary.


#28

@seanr
Can this be an ATT issue then being RW servers didn’t see it? I’m sure all carriers do drop calls/ messages. I guess fair questions are the dropped messages from the same people? What phones are they using? Can this be easily duplicated? Are they all on the same carrier?


#29

3 posts were merged into an existing topic: Galaxy S6 Where to buy for BYOP


Galaxy S6 Where to buy for BYOP
#30

@seanr
I understand mms is not guaranteed. That said, your answer is somewhat of a cop out. SMS and mms while not guaranteed from a technology standpoint are without a doubt consistently reliable outside of Republic. I can’t remember ever missing messages with AT&T or Google Voice. I’ve yet to hear back from support since Saturday. If you’ve been involved, would you kindly ask them to respond to my queries?

I really can’t stress enough that I am a big fan of Republic and the idea behind it. Not to mention the price. Unfortunately it’s not a new endeavor any longer so the bugs need to be gone.

@bocephous
In this case, AT&T and iPhone. In Past cases, missed messages from Verizon and Android. When I’ve attempted to duplicate, I have no success.


#31

Didn’t mean it as a copout, just a statement of fact that if it does not make it from one carrier to another there is no standard recourse to remedy. The other carriers will not accept tickets from us or guarantee delivery. SMS is more orderly and regulated. We are always working to fix what we can control. All we can do is apologize for the things we can’t.


#32

My wife has a Nexus 5x that constantly sent calls straight to voice mail rather than ringing first. I tried everything, but the only “fix” that actually worked was to turn WiFi off. My faithful Moto G1 on the same WiFi network always rings properly, so I don’t know what is different, but something is.

Of course, turning WiFi off pretty much defeats the purpose of being with RW’s technology, but it drove her crazy to constantly miss calls. Fortunately, with the v3 billing plan, we don’t really care about data refunds on her phone, we pay the same either way.


#33

Have you tested the 5X on more than one WiFi network? The fact another phone isn’t having issues using a specific network doesn’t necessarily rule out the network being the issue rather than the phone. It may very well be the phone but ruling out the network is worthwhile.


#34

Hi, Roland! The problem seems to occur when the phone has been idle for an hour or so, thus it is difficult to try on a different WiFi network. I use a really solid Century Link DSL with a less than one year old modem; it has extremely low FEC and CRC error rates, and I have no close neighbors and thus no local interference; I can only see a couple of other WiFi networks from my roof, certainly not from inside my home.

The Nexus 5x had another problem that RW was able to duplicate in their shop, but they had no fix for me, so maybe the phone is just not so good with RW service.


#35

General question about Republic Anywhere:
My understanding is that by switching to Republic Anywhere, the Republic servers receive the messages, cache the data, and distribute to whichever device / app is being used to access them (my computer or my phone). Is that correct?

@seanr
I did receive a response from support who is approaching it as a device issue. If your previous post regarding servers is accurate, and my understanding of Republic Anywhere is accurate, isn’t that a fools errand? I’m of course going to clear the cache on the phone and delete old messages as requested. Just curious since you seem to be plugged into this in some manner.

I won’t pretend to know the difference between types of messages and their intricacies. I’m just a bit befuddled with the thought that Republic would have lower reliability than other carriers but it be out of your hands.


#36

You point out the fact that this seems to occur after the phone has been idle for an hour or so … this is an indication that the WiFi is in sleep mode and the initial probe over WiFi from Republic failed and they then tried over the cellular network. Many have seen this problem across most Android phones (and not just on Republic). Some users have been able to bypass this sleep by adding a 3rd party app (Macrodroid)to provide a ‘wake-up’ to the WiFi. See Are your calls going to voicemail when your phone is sleeping? for a solution that was championed by @billg


#37

Thanks, jben! I installed the macro app and set it up then turned WiFi on. We’ll see if that solves the problem.


#38

This is my general understanding as well. Taking it a bit further, text messages are received by Republic’s servers for all of its’ 3.0 phones as well as any phone running the Anywhere client. In fact, Republic’s servers always received messages first. On legacy phones (Moto E1, E2, G1, G3, X1, X2), if and only if the message couldn’t be delivered to one’s phone over WiFi, the message would be handed off to Sprint for delivery via cell.

With 3.0 phones and Anywhere, messages that can’t be delivered over WiFi are delivered to one’s phone via IP over cell data with no handoff to the partner cellular carriers’ text messaging network. It’s over the top (OTT) IP data (WiFi or cell) similar in concept to Apple’s iMessage and should be more reliable presuming the text message in question hit Republic’s network in the first place.


#39

@rolandh
I’ve requested specifically from support to confirm our understanding as well as advise if the server ever sees our missing messages. Will update if I hear back.


#40

Jben: It has been a couple of days now, and every call has rung through perfectly. It appears that Macrodroid fixed the problem. Thanks!!!


#41

Rolandh: Jben suggested that I try Macrodroid and sure enough that seems to have cured the problem. Thank you for your input!


#42

The Macrodroid workaround has been successful for a number of Community members and I’m happy it’s working for your wife as well. Just to be clear, it’s helping with both the text messaging and calls going straight to voicemail issues, correct?