Galaxy S7 missing DTMF option under phone>settings>more settings

calling
#1

I’d like to change DTMF setting to long… but there is no menu option, although the manual says it should be there.

Bob

0 Likes

#2

Your phone may be different than mine but in mine:
-Open the “Phone” app
-Select the “:” looking icon (with 3 dots) in upper right side
-Select “Settings”
-Select “Calls”
-Select “DTMF tones”

Is yours different?

1 Like

#3

Hi @bobbtall,

Do you know if your S7 is provisioned for cellular coverage with Republic’s GSM partner or its’ CDMA partner? If GSM, the option you seek won’t be there.

If uncertain about which of Republic’s partners’ your phone is provisioned with for cellular coverage; please open the Phone app and dial *#*#786#*#* followed by the send key. Are you presented with a “Sprint DM” menu or does nothing happen. If nothing happens, your phone is provisioned with Republic’s GSM partner.

2 Likes

#4

Yup. Different. There is no “calls” under “settings”.

0 Likes

#5

All I get is a “dialed number not allowed” popup.

Sad.

0 Likes

#6

It means you are on GSM.

0 Likes

#7

I have CDMA and I get the same message, Dialed Number Not Allowed. Yes, I know for certain that my S7 Edge is CDMA.

Is it possible the menu changed since updating OS to Android 7?

0 Likes

#8

I am unable to get into voice mail because it is not recognizing my passcode… I have a funny feeling the constant “please enter you…” message is interfering with the tone when I press the keys. I believe the tone is too short. Is there any hope of getting a DTMF menu ??

0 Likes

#9

Hi @bobbtall,

A DTMF tones menu is absent on every GSM phone (not just Republic) in my household. I’ve only seen it on the two household Republic phones that are provisioned with CDMA coverage. You can mimic the effect of the long press DTMF menu function by pausing for a second to a second and a half between digits. Muting the microphone may help as well. If all else fails, there is the option of turning off WiFi and making the call into voicemail on cell.

All of the above said, I think the best solution is simply to listen to voicemail locally on the phone. There is no need to dial in. More here:

2 Likes

closed #10

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

0 Likes

Message an
Expert customer