Galaxy s7 won't ring for incoming Google Voice calls

#1

I moved from the Moto X 1st gen. to the galaxy. Google voice used to ring my moto X. Now, the new Galaxy doesn’t ring for incoming calls. Anyone else experience this?

Bob

0 Likes

#2

Solved it. Open google voice phone app. Under settings, under calls, select forward calls to linked number. It was unchecked as a default.

3 Likes

closed #3

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

0 Likes

Message an
Expert customer