Galaxy S8 "No cellular network available. Connect to an available Wi-Fi Network to make calls."

What phone do you have? Galaxy S8

What plan are you on? My Choice Plan, with Data

Does your plan include data, or just talk & text? Both


Issue Description

I’m in a city which should have coverage. I’ve got an unlocked Samsung Galaxy S8 which I believe doesn’t have WiFi calling. I was expecting to be able to make calls without WiFi though, but every time I try to make a call, and I’ve tried calling from a few different physical locations, the message “No cellular network available. Connect to an available Wi-Fi Network to make calls.” pops up.

I can’t even dial ##8647##, same message pops up.

Texting and browsing the internet (with or without WiFi) works fine.

Ideas on how to fix?

Hello @jeffreys
The first thing I’ll do is to reboot outside where you have a strong signal.

The proper code is *#*#8647#*#* [though you may have type on correctly but the forum software removes the*]

Here are a few follow-up questions?
Where did you purchase the phone/SIM?
What is the zip code? [so coverage and truly be rule out]
If SIM is from old phone what’s the color of the world ”Republic”? [2 tone grey or gery ”Re” with a green ”public”]
On the phone what does it say it’s model number is?

Yeah, I unfortunately can’t call that code because it gives the message “No cellular network available.”

I purchased the phone online (from Samsung), SIM online too (from Republic).
The zip code is 78750.
Grey Re, Green Public.
Model Number: SM-G950U1

Hi @jeffreys,

Sorry to hear you’re having this trouble, and very sorry your ticket has gone unanswered so long. How much longer are you in this city?

Every phone we support can call and text over Wi-Fi - it’s how our service works. Settings that are part of the phone’s native structure should be ignored, our service operates outside of that structure.

You must be on Wi-Fi for that code to work.

You have access to the internet when away from Wi-Fi. That would indicate this is not a coverage issue. I think this may be a residual issue from the outage we had late last week.

One of our technicians is now reviewing your ticket and will be responding there shortly.

I’ve been in Austin for a while, plan to be here for a while.

They responded and did reset some of the phone activation. Problem still persists. :frowning:

Sorry to see that problem persists, and I see that our support team is gathering some additional info from you. I’m sure they’ll be able to get this resolved.

Message an
Expert customer