Galaxy S9 Hulu no-go

This is not a republic issue I realize but anyone have advice?

Device: Galaxy S9
History: cord cutter since 2013, republic member since beta,

Current: can’t play Hulu show directly on my Galaxy S9 but can play Fubo. See error message from Hulu.
Current: find that the S9 has a hard time chromecasting - never had such problems with prior Moto devices.

Error duplicated: same error on the S9 whether using our home Hulu account our my small business’ Hulu live account.

1 Like

Hi @tamu_bu, :slightly_smiling_face:

I’m going to point you to Hulu’s Community. Take a look at these 2 posts. There are a few things people have tried that might help. :thinking:

https://community.hulu.com/s/question/0D53h00000jVieH/cant-play-on-this-displayhdcp-error

https://community.hulu.com/s/question/0D51L00006lRbEM/why-cant-i-view-programs-on-hulu-i-get-an-error-can-not-play-on-this-display

Added: I also see a key symbol on your screen shot. If that is a VPN you might try turning it off.

Just for giggles I just checked on my Note 20 and it works just fine on it. It appears the issue with the S9 has been going on since December 2019! There’s a thread of angry people here: HDCP error code. How do I fix this? (hulu.com)

The one common “fix” that I’m seeing in various places is that the Hulu App does not like it when any Accessibility Setting is turned on as it somehow interprets that as being a vulnerability for the video stream. Particularly I see the magnification gestures being enabled mentioned across devices as an issue. Do you have any of the accessibility settings enabled?

None of the accessibility services are enabled I saw where it seems a common issue for the S9 and S9+. I tried a couple of the basic suggestions mentioned in the Hulu users forums but those “fixes” didn’t do the trick for so many others or me.

Unfortunately it sounds like neither Hulu nor Samsung have found a consistent fix to this issue. Very odd.

Message an
Expert customer