Get message: Republic Wireless Keeps Stopping

What phone do you have? Moto G4

What plan are you on? Choice

Does your plan include data, or just talk & text? talk with 1GB data


Issue Description

2 days ago-message when i turn phone on a message comes up:Republic Wireless Keeps Stopping-
x Close App, send feedback. What is this all about and what to do>?

Hi @virginiac.mwqcn3,

Welcome back to the Community!

Try this procedure to uninstall and reinstall the Republic app:

Please let the Community know if it helps :slight_smile:

1 Like

I tried the procedure you recommended, now the message is :com.android., phone has stopped" HELP

Please try these suggestions from Tom’s Guide:

Tried suggestions in Tom’s Guide, but didn’t help. com.android.phone has stopped is still across the phone screen.

The last step to try after clearing the caches was a Factory Reset.
You tried that too and still get the “com.android.phone has stopped” error?

What phone do you have? motog4

What plan are you on? My Choce

Does your plan include data, or just talk & text? 1 GB data


Issue Description

Prob. started about 3 days ago.Message was Republic Wireless Keeps Stopping-I tried to uninstall RW, but unable to. Message now is com.android.phone has stopped working and I can’t get to Apps-message blocks and then screen goes to My Data page.

For these issues, I recommend the following steps to try to resolve your issue.

  1. Start with clearing the system and app cache.
    How to Clear Cache on Android – Republic Help

  2. Next, let’s make sure some app isn’t causing this by starting in Safe Mode? Use the phone in Safe mode for awhile to see if your issue keeps happening.
    Safe Mode – Republic Help

  3. Finally, if that doesn’t do it, you should try a factory reset. Beware, this deletes all the added content on your phone. The link also provides informational links on how to backup your data like contacts and pictures.
    How to Factory Reset a Cell Phone – Republic Help

The problem appears to be with the Republic Wireless app. Keep getting message RW keeps stopping. App permission needed. I tried to uninstall RW but couldn’t. Tried clearing cache, it was grayed out. I did try to open in safe mode, after holding the power button, I never got a message to OK safe mode. It is impossible to work on the phone with “com.android phone has stopped” across the face of phone. I don’t feel confident enough to do a factory reset.

Hi @virginiac.mwqcn3,

Candidly, it may not be possible to avoid a factory reset. How are you trying to uninstall the Republic app? Are you attempting to do so through Android settings or Google’s Play Store app? Is the Phone app also still crashing?

I have tried to do it both ways. When I go to the Play Store- Hit uninstall- Uninstalling…nothing happens Goes to Welcome to Republic Update App. When I hit Settings, page immediately goes to Welcome to Republic, Update app.

Clearing the cache didn’t help so i did a factory reset and the error message and Republic Update Now screen cleared off and the sound returned. I did not automatically reinstall any apps. I dread adding the Republic app back. Is it absolutely to install it?

  • The Republic App is required to allow you to connect to their system.
  • The problem you describe and the steps that were taken indicate (to me at least) … your phone was running out of memory. So not re-installing apps was an excellent choice.
    • If, after adding the Republic Wireless app the ‘fix’ holds, I would then suggest you begin adding your apps back in controlled groups, and it might be a good time to prune some of the apps you may have loaded in the past and are no longer needed.
1 Like

Thank you for responding.

2 Likes
Message an
Expert customer