Getting Nexus 6p to I.D. open wifi more actively?

I’m a longtime Rw customer who just changed from a Moto X 1g to a Nexus 6p; I’ve done all of the updates and the phone is running Android 7.0

My Moto X with RW was over-hyper trying to alert me to possible nearby wifi (frequently trying to steer me onto cable TV wifi of which I was not a customer).

But my 6p seems too passive in not offering an easy alert to/ connection steps to tie into nearby wifi. The only way I seem to be able to detect whether I am in a location with open wifi is by going into the phone’s general settings, and then, within settings, go into wifi- which is way too indirect and fiddly compared to something that will let me know that open networks are available and asking me if I want to connect

I opened a ticket 1:1 with RW directly over my 6p to ask about this, and was told:

"To enable network notifications, go into your Republic Wireless app and choose WiFi settings.

A few options down there will be a network notifications, scan for networks option.

Turn this setting on to enable notification for available WiFi networks."

BUT- in my 6p’s RW app (ver 3.8.2.3) of the sub-areas of the RW app seem to have any portion that is “wifi settings” - so I am not seeing any way for me to do what RW suggested

How do I get the 6p to be a little bit more active and intuitive to identify and have an easy interface to connect to open wifi? Thanks in advance

I suggest checking two things:

  1. Go into your android wifi settings. At the top right, there should be a settings wheel. Tap on that. It should bring up a ‘configure wi-fi’ menu. Make sure ‘Network notification’ is enabled, and "Keep Wi-Fi on during sleep is enabled.

If those are both already on, then:

  1. Go to Android settings, find the battery section. On the battery screen where it shows your app usage and projected time left, at the top right, hit the three vertical dots and tap on ‘battery optimization.’ There is a drop down menu that says ‘not optimized.’ Change that to ‘all apps’ then scroll down until you find "google connectivity services. Change that to ‘don’t optimize.’

If neither of those two things work, let me know!

Have you tried enabling Wi-Fi assistant? It’s a neat feature on Nexus and Pixel phones that will (sometimes) auto connect to completely open Wi-Fi and enable Google’s VPN. Information is at the link below.

Connect automatically to open Wi-Fi networks - Nexus Help

Message an
Expert customer