Gmail App Won't let in!

I switched phones yesterday, and I’m having problems checking my email. When I open the gmail app (and my email is gmail), it asks to either to add an email or take me to gmail. If I try to add my email it tells me that email already exists on my device. If I select “take me to gmail” it tells me to “Please add at least one email address.” I’ve tapped “Refresh List” several times hoping my email address would show up, to no avail.

Please help!

Hi @paulf.fmyvut - Welcome back to the Community!

Please make sure you’re opening the actual Gmail app (and not the regular email app) on the phone; the icon for Gmail should look like this:

image

If this is the icon you’re selecting, may I ask what phone you switched to? Hopefully we can get it figured out for you quickly! :slight_smile:

Thanks for the quick replay…yes I’m in the Gmail app…same app I used on my previous phone. I have a Motorola G7 Power.

Here’s what I’m seeing.

Thanks!

I’m going to assume it will, but I’d like to make sure so we’re covering all our bases. If you go to the Settings app on the phone & scroll down to select Accounts, does it show your Gmail account there?

Yes, it does.

Wonderful. So there are a couple of things that stick out to me in the screenshot you provided. It looks like there is a software update available for the phone (that is the icon in the top left that shows a cell phone with the arrows in a circle). Go ahead and follow these steps to get that software updated first: How to Update the Software on a Motorola, Google or Nexus Phone Running Android 8.0 Oreo or Higher – Republic Help

Once that is done, you may also want to check to see if there is an update available for the Gmail app. You can do that by following these steps: How to Update Apps With the Google Play Store – Republic Help

After both of these are done, go ahead and try opening the Gmail app again to see if you still get stuck at the same point. :slight_smile:

1 Like

The cell phone icon with the arrows in the circle was indicating I had a missed phone call. However, to be certain, I did check in my settings and my software is up to date, and, the app is, as well.

Hi @paulf.fmyvut - Been reading this thread and @richard.p has given you some good information and great checks to do. I’m not a Gmail expert (just another Community member) but a thought came to mind. Are you using 2 factor authentication (2fa) with Gmail? It’s my understanding that you have to move the Google Authenticator information to the new phone.

Hope you don’t mind me jumping in but just wanted to make sure the problem isn’t related to 2fa. My apologies if this post clutters up the thread with a 2fa question if isn’t being used.

I was not using 2fa with Gmail. However, to see if it would help I just turned it one, and it didn’t. Thanks for the suggestion. If anyone else has any ideas, please let me know.

Are the other Google apps like contacts, calendar and photos working correctly on the new phone? Everything is synced correctly. Trying to make sure this is a Gmail only problem.

2 Likes

Along with @freddyp’s suggestion, worst case, you could try removing the account & then re-adding it. Seems odd that your phone recognizes the account, but the Gmail app doesn’t. :confused:

2 Likes

@paulf.fmyvut - There is another troubleshooting step you can try. Reboot the phone in Safe Mode to make sure there are no 3rd party apps causing the problem. Safe Mode disables all 3rd party apps but does not remove them. This doesn’t make any system changes and is a quick troubleshooting step.

Just trying to think of troubleshooting steps that might lead us to the cause. And that’s often a process of elimination :smiley:

Thanks to all who offered help, and I apologize. I thought I replied to this earlier today, but it obviously didn’t go through. I did a factory reset and then I uninstalled the app, and reinstalled it through the App Store. I am 99.9% certain I followed the same steps as I did the first time, but it worked this time for whatever reason.

4 Likes

@paulf.fmyvut thanks for reporting back and sharing the solution that worked for you. This might help another member that has this issue. Sharing is a good part of the Community and what our members do to help each other.

2 Likes
Message an
Expert customer