(Google Android) Messages: Group Messages Sent Individually -- Here's the fix!

Is there anything useful in that “More settings” option?

Is that a Samsung phone? I’m thinking that may be the Samsung Messages app. I’m afraid that’s not an app our service supports (it’s not compatible with Republic Wireless) so I’m not familiar enough with it to answer your question.

Perhaps @louisdi knows?

Yes it’s a Samsung phone so it’s most likely the Samsung messaging app. No there isn’t anything useful in that more settings option unfortunately. Sorry to bother you. I didn’t know. I was forwarded this site from a friend.

Hi @jeffm.xnncca,

That’s definitely Samsung’s Messages app. It seems like you might be using your Samsung phone with a service provider other than Republic Wireless. If I’m right about that, please know folks are trying to help based on what works for Republic members. Republic likes to call customers members.

I believe the settings you’re looking for are as follows:

  1. Open Samsung’s Messages app
  2. Tap the three dots upper right
  3. Tap Settings
  4. Tap More settings
  5. Tap Multimedia messages
  6. Toggle Group conversation on

Again, the above presumes you’re not currently using Republic for mobile phone service. Might the friend who directed you here be a Republic member?

1 Like

Hi @jeffm.xnncca,

No need to apologize, we’re happy to help. Please let us know if @rolandh’s suggestion gets group messaging working for you.

I think @rolandh gave me all the right steps to follow. I did everything he said and it’s still not working but the steps he gave me make sense. I think my problem is with my service provider. Group texting stopped working as soon as I switched providers so I will be phoning them today to get it sorted. Thank you guys. Your help has been great!

1 Like

Good luck @jeffm.xnncca, I hope you enjoy that on-hold music! (Endured 30 minutes of it the last time I had to call them!)

Of course, there’s another solution… if that Samsung phone is compatible, you could bring it to Republic Wireless. :smile_cat:

1 Like

Hahahah thanks. If I lived in the states I would. Unfortunately for me your service isn’t in Canada yet :sob:

2 Likes

Nothing in here seems to work for me. I posted a screen shot of what shows for me.

Hello @Anthonyrcsmith
That looks like the Samsung messages app which is not compatible with Republic for MMS [all group messages are MMS]
The solution here is for Messages by Google :messages:

3 Likes

I just wanted to say thanks because this is the very first time ever that any online help has actually worked!

5 Likes

This is great & thanks! I would just add that you need to make sure you are in the home screen of the app to get to settings (I kept wondering why my little 3 dot menu didn’t have any settings and it was because I was in a specific conversation).

BINGO! Thanks so much. It was very frustrating but now I feel like a human again.

What a simple and easy fix if you know about it!

Why in the world would the default to a group text be to send individual messages out rather than stay in the group?!!

3 Likes

OMG had this problem at least 2 years if not longer and somehow only stumbled upon this post now? THANK YOU!!!

3 Likes

I need help! My phone have the same issue but in advanced I don’t have any group messages option. I have only chat option. What I can do?

Hi @magdag.eqofra and welcome.
To better help you, the community needs to know what phone you are using, and that you are indeed using Google Messages app.

This is what I meant and my phone is Xperia 1

Hi @magdag.eqofra,

You’re participating in a Republic Wireless Member Community. The users here are Republic Wireless users and are familiar with the phones, processes, and policies unique to Republic Wireless.

Republic Wireless does not support the Xperia 1.

2 Likes
Message an
Expert customer