(Google Android) Messages: Group Messages Sent Individually -- Here's the fix!

Thank you for the advice.
Worked perfectly for me.

1 Like

Thanks, needed this for my new Moto G6 play. Knew I needed MMS but didn’t know where or why it was turned off.

1 Like

I’m having this problem and this isn’t helping me. I can find the settings but there is no advanced after that. I have searched and searched how to switch it from sms to mms but have had no luck. I just want to be able to send group messages and not annoy my friends by having them sent individually. It was working fine until I switched providers to virgin. Help please.

The Google Messages @ 3.9.039 (latest level avail) shows the Advanced functions being discussed on Republic Wireless , perhaps the folks at your new provider may be of some help?

3 Likes

Hi @jeffm.xnncca,

Let’s make sure we’re on the same page.

First, you’re using the Messages app by Google, with this icon: :messages:, yes?

Second…

Can you tell us the exact steps you’re taking to open the settings, and perhaps share a screenshot so we can see what you’re seeing? “Advanced” is all the way at the bottom of the Messages app’s Settings menu.

1 Like

I’m not sure if it’s Google or what it is. It’s group texting. Here’s some screenshots of the steps I take. I click messages at the bottom left screen, then the 3 dots in the top right corner, then settings, then more settings? From there, I’m lost. I can’t see anything of the sort. I just want to be able to send messages in the group text with my friends. I hope the screenshots work here…

Is there anything useful in that “More settings” option?

Is that a Samsung phone? I’m thinking that may be the Samsung Messages app. I’m afraid that’s not an app our service supports (it’s not compatible with Republic Wireless) so I’m not familiar enough with it to answer your question.

Perhaps @louisdi knows?

Yes it’s a Samsung phone so it’s most likely the Samsung messaging app. No there isn’t anything useful in that more settings option unfortunately. Sorry to bother you. I didn’t know. I was forwarded this site from a friend.

Hi @jeffm.xnncca,

That’s definitely Samsung’s Messages app. It seems like you might be using your Samsung phone with a service provider other than Republic Wireless. If I’m right about that, please know folks are trying to help based on what works for Republic members. Republic likes to call customers members.

I believe the settings you’re looking for are as follows:

  1. Open Samsung’s Messages app
  2. Tap the three dots upper right
  3. Tap Settings
  4. Tap More settings
  5. Tap Multimedia messages
  6. Toggle Group conversation on

Again, the above presumes you’re not currently using Republic for mobile phone service. Might the friend who directed you here be a Republic member?

1 Like

Hi @jeffm.xnncca,

No need to apologize, we’re happy to help. Please let us know if @rolandh’s suggestion gets group messaging working for you.

I think @rolandh gave me all the right steps to follow. I did everything he said and it’s still not working but the steps he gave me make sense. I think my problem is with my service provider. Group texting stopped working as soon as I switched providers so I will be phoning them today to get it sorted. Thank you guys. Your help has been great!

1 Like

Good luck @jeffm.xnncca, I hope you enjoy that on-hold music! (Endured 30 minutes of it the last time I had to call them!)

Of course, there’s another solution… if that Samsung phone is compatible, you could bring it to Republic Wireless. :smile_cat:

1 Like

Hahahah thanks. If I lived in the states I would. Unfortunately for me your service isn’t in Canada yet :sob:

2 Likes

Nothing in here seems to work for me. I posted a screen shot of what shows for me.

Hello @Anthonyrcsmith
That looks like the Samsung messages app which is not compatible with Republic for MMS [all group messages are MMS]
The solution here is for Messages by Google :messages:

3 Likes

I just wanted to say thanks because this is the very first time ever that any online help has actually worked!

5 Likes

This is great & thanks! I would just add that you need to make sure you are in the home screen of the app to get to settings (I kept wondering why my little 3 dot menu didn’t have any settings and it was because I was in a specific conversation).

BINGO! Thanks so much. It was very frustrating but now I feel like a human again.

What a simple and easy fix if you know about it!

Why in the world would the default to a group text be to send individual messages out rather than stay in the group?!!

3 Likes
Message an
Expert customer