Google error keeps showing up

Hello!
The Google app on my Android J7 phone suddenly started freaking out a couple of days ago, showing the ‘Google keeps stopping’ error. Now it shows up so often that I can’t write anything in search bars (even in other apps). It shows up everytime I even touch the screen. My phone basically keeps glitching out this error every second or two and my phone is unusable. I tried restarting my phone, clearing cache, clearing data, disabling and force stopping Google but nothing has worked. I tried turning off notifications, uninstallind and re-installing all updates but again, no results! I am even wondering now if it’s a virus or something. I am writing this from another device :frowning:
Please help!

  • Try putting the phone in Safe Mode for testing this will help eliminate a 3rd party app that could be the source of the problem
    • If this makes it better, come back for help in tracking down the app or update that may have been the cause
2 Likes

Thank you for the advice! Unfortunately, it didn’t work. Still can barely use it!

Hi @aminak.kpgc2b

Give this a try. From a computer, log into https://play.google.com/store/apps/details?id=com.google.android.googlequicksearchbox&hl=en_US. Click the “install” button, select the appropriate phone if there is more than one on associated with your Google account, and click “install.”

I’m hoping there’s an update out there you can force to the phone and clear up the issue.

2 Likes

Nope, all updates are installed on all the connected devices! Thank you, though :slight_smile:

1 Like

Hi @aminak.kpgc2b

Here is another suggestion from someone that had the same issue:

https://support.google.com/websearch/forum/AAAAgtjJeM46SwmUWo2yFU/?hl=it

The fix:
" rolling back the updates to google app and reinstalling them fixed the problem."

Try going to your phone settings (the gear) and then all apps and notifications… then look for the Google app. Tap on it and tap on “Disable” (that should bring the app back to factory setting (It will not uninstall it). Then re-enable it and go to the Play Store as suggested by @southpaw and run the update.

Hope this helps. :slight_smile:

Added: It looks like you might have tried this already… If so I’m sorry for missing that.

1 Like

Thank you, too! Ah, yes, I have tried all of those. I was actually looking at the same suggestion this morning.

1 Like

I’m afraid you might be looking at having to do a Factory Reset.
(Please remember to have your data backed up if you do.)

2 Likes

Bingo! That solved it (finally!). Thank you for your help🌸

2 Likes

You’re Welcome :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer