Google maps says GPS signal lost

What phone do you have? Moto G4 Play

What plan are you on? MyChoice +1GB

Does your plan include data, or just talk & text? Yes, 1GB data


Issue Description

For the past few months, I’ve noticed that my phone has had a hard time getting a GPS signal on Google Maps. It fizzles in and out constantly. One moment it tells me the “GPS signal is lost” and then I get connected again, and then it gives me that message again. It’s really annoying when I’m driving to a location I’m unfamiliar with. I’ve tried taking off my phone case in hopes for a better signal, turning my data off and back on, turning location off and on, turning my phone off and on…nothing. Is this a Google Maps issue, or does my G4 Play have compatibility issues? Also, I might add that I used to use Waze on my old phone with AT&T because it’s so much more helpful with reporting traffic and construction, but I’ve never been able to use it on my Moto G Play with Republic and I wish I could. It’s really making me wonder if it’s my phone and not the apps. Is there anything I can do to fix this? EDIT: This issue happens even if I have full coverage and my location is turned on. Also the GPS is set to high accuracy.

GPS Signal can be affected by a variety of factors. Weather, geography, and the phones antenna.

Have you recently dropped the phone?

Does this happen when it’s storming, or when driving up and down mountains?

I’m not sure if clearing the cache or booting into safe mode would help an issue like this but it doesn’t hurt to try.

3 Likes

I have this problem even with clear skies, good weather, non-mountainous areas, and with my phone case off. Google Maps has never had a problem working on my phone until recently. I have dropped my phone a few times, but I have a case that absorbs shock, so I’m hoping that whatever mechanisms the GPS uses are still intact. Putting my phone into safe mode disables my Republic apps therefore my data is absolutely useless while in safe mode. I’ll try to clear my cache and see if that helps.

GPS does not use the cellular or wifi radios.

If the phone is within warranty this sounds like something that will probably need to be repaired. If so, contacting Motorola would be the next best step. (If clearing the cache and safe mode don’t work.)

1 Like

But you do need data to look up the address on Google maps right? Unfortunately I don’t think my phone is under warranty so if it needs to be repaired I’m not sure how much I’d have to pay.

Google maps does have a off line mode which can look up address it just will not have traffic info

https://support.google.com/maps/answer/6291838?co=GENIE.Platform%3DAndroid&hl=en

2 Likes

I’m having the same issue with a samsung galaxy s6, did you find a solution?

I don’t know what I did but it’s working again. Sorry I can’t be of more help.

Ok I figured it out I think. Taking the case off works for me. I’ve never had that problem before. And I even tried putting my old case on that I used when the map worked and now it doesn’t. Try taking your case off. I guess last time I didn’t wait long enough for it to sync up with the sattelites. Impatient me! Lol

Hi @jennab.u1mf3x,

Thanks for following up to let us know!
What kind of case were you using? Could we send you an Incipio Octane in Black and Frost so you can see if it does the same thing?

@southpaw It’s just a case I got off of Amazon…can’t remember what brand. All of my cases have been silicone though. But like I said, in the past I didn’t have a problem and now suddenly my GPS doesn’t want to work with a case on. I don’t think I need a case sent to me. Thanks though!

1 Like

I have the same issue while using my Motorola E 2nd Gen and using Google Maps in offline mode. This issue has only started to occur within the last few months as it never happened previously. Sometimes even after the message, “GPS signal lost”, the app recovers and proceeds as normal. As a side note, I had to perform a factory reset on my phone in an attempt to resolve a different issue. This message continues even after the factory reset was performed.

I’m having the same exact issue with my Moto E 2nd Gen using Google Maps offline and it only started a few months ago. I reinstalled Maps and was going to do factory reset, but i read here it didn’t help. It also takes a very long time to load and is not responding to tapping the screen. It also looses satellite location. The app continues to run after closing it and I have to turn the phone off to closes it. Unfortunately, it’s not dependable and very frustrating. Has anyone resolved this other then replacing their phone?_ Are phones only good for 2 years or less?

Also, installed GPS status to better locate satellites, as recommended in one RW post, and it made a little improvement but still loose satellite connection. I did drop my phone once, but it is in a protected case.

Have you tried removing the case to see if that makes a difference to signal. GPS signals aren’t very strong and can be further weakened by everything from thick cases, to the metal in your car, to walls, etc.

I don’t have an external case. The GPS status app is suppose to assist in finding the strongest signal. I’m starting to suspect it’s the phone, as others are having the identical problem with same phone. I wish I could install an older version of Maps to see how that works. thanks

The Moto E2 has been out there a long time (over 3 years) and lots and lots of customers have it, and there haven’t been any threads on GPS problems with the model here, so I don’t think this is a model issue. Have you tried simply downloading Waze or one of the other navigation apps to see if there’s any difference?

No I haven’t.
Can you use Waze offline, like Maps?

Waze doesn’t work off lines, however you can try Here which does: https://play.google.com/store/apps/details?id=com.here.app.maps

Thanks I’ll try it.

Message an
Expert customer