Google Messages for Web - Can't send texts when phone is asleep in Doze mode

What phone do you have?
google pixel 3a XL

What plan are you on?
1 GB

Does your plan include data, or just talk & text?
Data 1 GB


Issue Description

Google messages for Web. I can receive texts but cannot send any when my phone is asleep in Doze Mode. Says “Not Sent. Click to Try Again.” As soon as I wake my phone up it goes through. If I dont wake my phone up, it never goes through. If my phone is awake, google messages for web works perfectly. Any ideas on how to resolve this problem?

Hi @brandong.i1aaku – you might want to read up on some options using MacroDroid.

We use a KISS30 macro on our G6s with good results. Simply wakes the phone every 30 minutes. We are heavy users of Google Messages for web via our laptops and this seems to address any issues with Doze.

YMMV

3 Likes

@freddyp Thank you. How involved is setting up the macro and are there any other “side effects” that come with it? I haven’t read through the detail, but just taking a quick look at the link you sent to set up the macro looks really time consuming. I was hoping that potentially there was an easier fix to get google messages working properly. Very surprised that google would have a text messaging application that does not work without a complicated work-around…Maybe this issue with google messages for web and Doze mode is only an issue with certain phones?

There are many factors that seem to impact Doze. Don’t think it is necessarily a phone specific issue. The latest version on Android does seem to be more aggressive in using Doze.

The KISS30 is pretty simple. Here’s a link to the details and discussion in the referenced thread.

The complete thread has several macros that members have developed and used with varying degrees of success. Those are based on certain notifications. KISS30 is brute force method that simply turns the display on every 30 minutes. The display shuts off after 15 sec so there is very little battery drain. On our Moto G6s that seems to work well.

@freddyp Thank you. I am looking for the simplest approach to resolve the Google Messages for Web issue, so I will look into the KISS30 macro as you are recommending. Doze is annoying in general, but since I have decent cell coverage, the main issue that impacts me is the google messages for web functionality. Are there any disadvantages of the KISS30 macro vs the others? Any reasons to consider any of the other macros?

I have to give credit where credit is due. Most of the heavy lifting in using MacroDroid to address Doze issues was done (and continues to be done) by @jben and @billg. In fact, KISS30 is a take off from original work done by @billg.

The only disadvantage I see with KISS30 is there could be some slight increase in battery usage. We have two Moto G6s so had the luxury of putting one phone in test mode for 24 hours with just the macro running, nothing else open and consuming battery. The battery usage showed no measurable difference in battery usage app. Let’s face it – the screen is only on for 15 seconds every 30 minutes (or a total of 30 seconds each hour).

Especially like the simplicity of screen operation. Typically the screen turns off in 15 secs when it turns off automatically after macro run but when screen is unlocked screen turns off at whatever the user has set.

FWIW - we have no passwords set anywhere on either phone. We keep it super simple :grin: Doesn’t take long to install MacroDroid and build macro and see if it helps!

@freddyp Got it - thank you. So, once I install the Macrodroid app, will there be an option to select the KISS30 and I am done, or is it something I have to build myself using instructions/settings that you specified in the link you sent? If it’s only using 1-2% battery over a couple days, that’s not bad at all, and well worth it to get google messages on my computer working.

You have to build the macro. MacroDroid makes it pretty easy. I’m not a MacroDroid expert by any means and still got it done :grinning:

@freddyp Thank you. I assume the instructions for how to build the KISS version are in the link you sent. I will review that shortly. Thanks! (still struggling to understand how google has apps that just dont work due to doze mode, and there isn’t just a simple “disable” button that can be pressed on my phone…but luckily we have great support from people like you all to figure this stuff out!)

I don’t know if it’s practical, but if the phone is plugged in it won’t go into doze mode.

4 Likes

Good catch @cbwahlstrom. That’s normally one of the first troubleshooting steps I mention to see if an issue is truly related to Doze. As my hair grays I seem to forget more :confused:

2 Likes

@cbwahlstrom Thank you for the suggestion. I suppose I could keep my phone permanently plugged in, but that doesn’t seem practical. Also, not sure about the long term impact on the battery by keeping it permanently plugged in. Maybe @freddyp or others can weigh in on potential battery impacts.

1 Like

Hello @freddyp and everyone. I just wanted to post an update after installing the KISS30 Macro. Thank you to @jben and @freddyp for your help with this. Installing the KISS30 Macro totally solved my problem. Google messages works perfectly now. When I would get a call after my phone was idle for a while, it would sometimes come through using cellular, and now it will always come through on wifi. I have decent cellular service in my area, but for people who don’t and are having issues with calls going directly to voicemail or texts not coming through until phone is activated (or if you have issues with google messages), I would highly recommend installing this macro. There is some mild increased battery usage, but it seems to be negligible, especially relative to the benefits of the macro. Thanks again!

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer