Google Play Download Pending


#1

I have a Alcatel Phone and in google play whenever i try to download an app it just says download pending. What can i do to fix this?


#2

Hi @hank112489,

Is the phone on Wi-Fi when you try to download? Is this happening for new apps you want to install, or for updates to existing apps?


#3

Yes i am using Wi-Fi it is happening for both updates and existing apps.


#4

I see that happen occasionally. Though mainly when first setting up the phone.
Have your Tried rebooting the phone and giving it a few minutes to settle before trying to update anything?

You can go into the app info for the Play Store app and clear the app cache and data, then reboot.
That has fixed that issue for me a couple times.


#5

Hi @hank112489,

It’s been a little over a week since we’ve heard from you. are you still having trouble with the Google Play downloads, or did the suggestions by @SpeedingCheetah help?


#6

I have attempted unsuccessfully to resolve the Download Pending issue with the Google Play Store. I tried you’re suggestion with the same results. (I have cleared the data and cache both in Google Play Store under the Storage option. The reboot option was used before and after the steps just mentioned with no success at all.
WiFi is fully operational. The same results are obtained with any app I wish to download.
My wife’s phone is still being paid for. Can I return it? It’s an Alcatel model A576RN, Android 7.0 with a 12/1/17 patch, build vS3E.

My phone does not have this issue.
Help Help Help Help out there in support world.


#7

Hi @john.anthony,

Sometimes the Play Store will not allow you to update or install new apps unless the Play Store and Google Play Services apps are up to date. Do any of those apps or any of the system apps on the phone indicate they have updates pending?

I’ve reviewed our help tickets looking for other members who have had trouble installing apps through the Google Play Store on the Alcatel A30, and the only other recent instance I could find was solved by factory resetting the phone. That would be required before a return anyway, so it’s worth a try as your next step.


#8

What information would I lose?


#9

Also i had the same results as other people.


#10

You might check and see which version of Google Play Services is installed on your phone. I am using an Alcatel A30 without any problem. It is on version 14.7.99 of Google Play Services installed on Nov. 29, 2018.


#11

Thanks for your support interest in my wife’s Alcatel A30 phone.

I followed up with your recommendation on looking for any pending updates, and I did not see any at all in the 40 odd apps on the subject phone, or anywhere else on the phone as a whole.


#13

Hi @john.anthony,

Did you see @cbwahlstrom’s question as to what version of Google Play Services is installed on the phone?


#14

Yes… I’ll pursue that avenue as a possible solution.


#15

Kathy’s Alcatel A30 version of Google Play Services is 14.3.66

Can this phone accomplish an upgrade to 14.7.99 which does not have the ‘Download Pending’ problem?


#16

To be clear, I’m not sure that your issue is related to having the most up to date version of Google Play services, but it may be a strong indicator. Try following the steps below to ensure that Google Play Services are working correctly:

  1. Update Google Play Services – To check if you have the most up to date version open the Google Play Store and search for Google Play Services or click this link. You should see a button that says Installed, if you have an old version you will see an Update button. If Google Play services updates, stop here.

google-play-servuces

  1. Clear the Google Play Services cache – Sometimes the files on your device can get clogged up, so it’s always useful to clear temporary files from your apps that you don’t need.
  • Go to Settings > Apps.
  • Scroll to All apps and then scroll down to “Google Play Services” app.
  • Open the app details and tap on the “Force stop” button.
  • Then, tap on the “Clear cache” button.
  1. Restart the phone

  2. Repeat Step 1


#17

Tried your instructions.
opened google play
located google play services
had a problem at this point…
You should see a button that says Installed, if you have an old version you will see an Update button. If Google Play services updates, stop here.
Found Carrier Services Update… selected INSTALL …. resulting in Download Pending…


#18

I’m unclear as to whether or not you were able up successfully update Google Play services. Did Google Play services offer an update button? Did it update? If not, proceed to step 2. Or if you’re tired of dealing with the issue, declare thermonuclear war on the phone and perform a factory reset.


#19

I defer to the thermonuclear option.