Google play store, adding apps

#1

My old moto x won’t add apps. When I try I get these prompts: “Complete action using, (choices) browser, play store > (no matter which I choose) this browser is no longer supported > please use the google play store app to access google play >server error, retry”.

#2

Hi @travisinman

Have you tried signing out of the Playstore and back in?. I would give that a try to see if it corrects itself.

#3

In addition to the excellent suggest give by @c1tobor, a simple off/on power cycle often corrects strange issues like this. If you’ve already tried that, please disregard this recommendation. In case you’re thinking of throwing the phone against the wall, that won’t help, either. Don’t do that.

1 Like
#4

I can’t GET IN to google play at all… “server error try again” is all I get.

#5

If you have access to a computer, go to Google Play and login that way. If you don’t have access to a computer, you can try deleting the Play app (it will only delete updates). That may give you access to the version of the Play app with no updates. Once in, you can update the Play app like any other app.

Also, try a VoIP reset. On the dialpad, key in ##8647##

closed #7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer