Google Services Framework

What phone do you have? Moto X

What plan are you on? My Choice Talk & Text + 3 GB Cell Data

Does your plan include data, or just talk & text? all 3


Issue Description

my issue began this morning when I turned on my phone. There is a dialog box that says Google Services Framework installed (which I had never heard of prior to this morning & certainly never installed on my phone). It gives me 2 options: About & Close App.

When I click on Close App, the entire box disappears for about 1/2 of a second and the same message displays again.

When I click on About, the screen changes below & I can see 2 buttons: Disable & Remove App, but there isn’t enough time to select either one.

We tried calling my phone from another phone, & my phone rings, but there’s no way to answer the call.

I have tried restarting and powering down completely, but the same dialog box appears.

I was able to swipe the button on the bottom of my phone to view open apps, but still it will NOT let me swipe it to close it.

Help please…I would really like to use my phone again!!!

Thanks in advance for your support {name redacated}

Hi @ddirving.681uwh, :slight_smile:

Please try going into the phones settings > apps & notifications and tap on “see all apps”.
Now tap on the 3 dots in the upper right and tap on “Show system”.
Please scroll to the Google Services Framework app and tap on it to open.

Tap on Storage and cache and clear both.

Restart the phone then check in the Play Store for any updates.
Please let us know if this helps :slight_smile:

I can’t get to my settings. It won’t let me access anything at all.

Dear Super T…I’m soooo bummed…I’ve been watching the pop-up menu…thinking an expert would respond there…thank you in advance if you can help me to figure this out.

Hi @ddirving.681uwh,

I’m sorry you’re still getting that pop up. :confused:
It sounds like it blocks access to the settings…

You say you have a moto x on the My Choice plan so I’m going to assume it not the original or the 2x. Let’s see if you can clear the system cache…

Hi Super T-- I made it to #5 on the procedure, but it says to select the “Wipe Cache” option.

I don’t have that option available…& the closest seems to be “Wipe data/factory reset”

What will I lose by selecting factory reset?

Or is there another menu to access that will allow me to find the “Wipe Cache” setting?

Thanks for your patience & sticking with me to continue to solve this issue!

Also, the list of phones for this procedure only lists the MotoX Pure Edition. Is there a way to determine exactly which one mine is?

Also, if you could provide me with a phone #, I do have access to another phone in the house that I could call you to discuss this…

And I’m in the Mtn time zone & will be available now…continually monitoring this so that we can hopefully get to the bottom of this issue soon.

Thanks again, Lisa

Hi @ddirving.681uwh,

Our Member Community is largely made up of Republic Wireless members helping one another with questions that don’t require account access or a technician’s action on back-end functions. The conversations are publicly visible in our Member Community, which allows others to search the Community and find answers to their questions, often without even needing to ask the question, but also so that multiple people with experience in the issue at hand can chime in and offer assistance. We would discourage our Community members from trying to move the conversation to a private telephone conversation, both for security reasons and because that limits the number of people who can try to assist you.

If you find you need assistance with this issue over the phone, please let me know, and I’ll move the Help Ticket you opened to a team who can help you by phone.

You can log into your Republic Wireless account to see what kind of phone you have.

Dear Southpaw–

Thank you for the offer to move this issue to a help ticket to receive phone help.

How will we connect by phone? Will you send me an email w/a # to dial?

I’ve gone to my account & cannot locate what kind of phone I have?

Thank you so much, Lisa

Our Help Team will be in touch with you by Help Ticket at https://help.republicwireless.com/hc/en-us/requests/2119469.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer