Google's new Call Screening

Sorry you went to all that effort @zipler, but I’m glad you thought to check here and found what you needed to know. (Welcome back to our Community, it’s been a while!)

Thanks, it sure has been awhile… But, that’s a good thing. When there are no problems, no need come here!

Reading the forums I found an ok workaround for now (blocking the port on my firewall) which will only work at home. I may look for a firewall app on my phone to block it on other networks, but I like to keep the number of apps on my phone to a minimum… (To preserve battery)

Either way, it’s not a big deal and I’m just glad my microphone isn’t actually being used by an unknown app.


1 Like

We posted bug reports to Google about this issue with our OG Google Pixel phones using the recommended language. This is a real bummer since one is also exhibiting the infamous microphone/sound board issues and will need replacement. As a newer Pixel is out of the question since they all seem to have the call screening issue, I don’t know what phones we would replace them with.

Is it too much to ask that Google make this “feature” have a simple on/off switch to enable/disable it rather than force the unnecessary breaking change on us? Doesn’t seem that hard and would actually let my PHONE be used like a PHONE instead of breaking the namesake feature of the device!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

per southpaws suggestion i used the following wording to open a ticket with google. they had absolutely no idea what i was talking about. nobody could find a dev ticket. Google was pretty adamant that this is something that RW needs to solve. i would imagine google has it figured out since I believe their google fi uses wifi calling as well. The last update from republic wireless was february, saying that google has not addressed the issue. . . has republic followed up at all? i would imagine RW customers want to use all the features of the BYOP google pixel. . … that they already bought. . .

“Hello, I am using a Pixel {insert your model number} on VOIP service provider Republic Wireless which is using call routing over Wi-Fi. The issue is that inbound Call Screening crashes consistently for incoming VOIP calls. Otherwise, their Wi-Fi calls work fine with the system dialer. Could you suggest a workaround other than to disable the Phone permission for the Republic Wireless app, as doing so prevents Wi-Fi call routing from occurring? I reached out to Republic support, who indicated that their developers have opened a ticket reaching out for Google’s assistance in resolving this bug. Could you please add priority to the dev bug Republic Wireless has opened? Ticket: 118842037”

Google doesn’t seem to care.

Anyway, the Call Screener is NOT a tool to use to help reduce spam calls.
It makes them worse since it makes the spammers/robo calls system know it is an active number because the call is answered and a voice is heard.

To reduce spam calls, u answer the call, immediately put it on mute, and it appears to be a dead line/ not a valid number to those robo systems…it is a proven trick that my boss recommended i try. Every person I have told to try this, after a few months, they had very little spam calls.

That’s fine that it is not a tool to reduce spam calls as I prefer to use it to SCREEN calls, as it is aptly named…

Hi @kellyz,

Thanks for trying to add your complaint to this bug with Google. Our engineers noted that because it is a “Google Dialer Bug” and those are not publicly visible, you would not be able to see and upvote the ticket like a normal Google bug ticket, but the fact that they would tell you it doesn’t exist when you have the actual ticket number is incredible.

I’ve let our engineers know of your experience. They’ve studied the issue in depth and without action by Google, they do not have a solution.

1 Like

I upgraded my Pixel 3A to Android 10. This has changed the behavior of this bug but not for the better. Now my phone appears to screen the call. It displays what the Google screening agent is saying to the caller. However, the caller DOES NOT HEAR ANYTHING. To me, it looks like the screening is working, but the caller is just getting a muted line. If I disable the WiFi, the function continues to work normally.


I’ve joined the club. I just upgraded to the Pixel 3 with Republic specifically because I wanted to make use of the call screening feature, and am now experiencing the issue of the caller receiving no audio from the Google Assistant.

I appreciate that there are some issues on Google’s side, however given the current known workaround of “disable wifi” which restores the correct behavior, could I ask the republic team to please consider allowing handoff to 3g for inbound calls? Ideally, if you could detect when Google Assistant is screening the call, you could disable WIFI… but if that’s not possible then please consider providing a workaround within the Republic App config?

My present workaround is to disable WIFI calling entirely, which is, unfortunately, far worse :-/

Best regards.
– Republic fan since beta; desirer of Google Assistant

Sharing my current workaround for the “google assistant is silent” behavior:

When a call is coming in and I decide to use google assistant:

  1. tap ‘screen call’
  2. Immediately pull down the top menu and disable WIFI

Within a second or so, the assistant will regain her voice, and the caller will hear her introduction. Call screening will work correctly from here on out.

Could you share the details on this port blocking please? I might be able to put together a little android app to generalize this solution. :slight_smile:

If you block UDP port 5090, all incoming/outgoing calls will occur over cellular. Normally you do this on your home router.

1 Like

Thanks for sharing your workaround, @blinkymach12,

Our engineers are evaluating a potential workaround within the RW app that would not require Google’s collaboration. This is not a quick process, so we appreciate everyone’s continued patience!

We can pause any further submissions of tickets with Google from our Community until this evaluation is complete.


So now it seems that Google is making the Call Screen Automatic.
I wonder if this will snarl things up for RW users since this feature still is not compatible.


For what it’s worth, the linked article refers to it as an option, so at least, it would seem possible to turn it off. Thanks for the heads up!

I just had this happen when I call screened on wifi on my Moto g7. I’d used this feature before on wifi and it had worked fine. But now i got the immediate call drop after I hit screen call and the RW popup.

Hello, recently picked up a Pixel 4 to replace my old g5. Luckily I tested call screening with some friends before using it. Very disappointed. Found this post. Is there any updates on how this process is coming along? Anything we can do to help outside the Google Ticket?

Hi @koltona,

Thanks for your willingness to help. Posting here to keep this topic fresh and give us some awareness of the amount of demand there is for getting this working is actually helpful.
I’ll check in with our developers to see if there is any news.

Message an
Expert customer