Google's new Call Screening

It worked! Well kinda.
I received several calls as tests and the feature worked every time. The only fly in the ointment was the caller reported that every time I screened the call and then accepted it, they would have an echo of their voice on their side. My side of the conversation was always good.
I had them repeat the calls and I would pick up without screening. No issues.
I called them… no issues.
I had them call me from a different phone again testing the screening and again they would hear an echo of themselves.

(This is at home in airplane mode with WiFi on)

1 Like

Thanks @rolandh and @SuperT!

@SuperT, I’m not hearing that echo when I test.

I updated every Google/Phone-related app on my phone (I tend to forget to do the updates :see_no_evil:) and it’s now working on my Moto G Power, as well. :southpawpoms:

@koltona, may we send you a Republic Wireless T-shirt as your prize for being the one to notice it’s working and letting us know?

1 Like

I’m actually hearing a very light echo, but it doesn’t seem to be related. I’ve never even noticed it before until now. I got the echo on both call screening and directly answering the call. No echo on the caller side.

@southpaw I would be very happy with that. I’m not active here, but I tell everyone I can about Republic Wireless. I will admit this specific issue had driven me to Google Fi’s checkout page a few times, but I stuck around and am glad that I did.


Strange, I had another person call as a test ( a Republic Member this time) and he too got the echo. :man_shrugging:

1 Like

Call screening is also working for me on a household Moto G Stylus in addition to my Pixel 4 XL. I’ve not noticed any echo related to call screening or otherwise.


Yay! I updated to Android 11 the other day and just thought to check if Google call screening works now and it does on my Pixel 3a!

Or it did the one time I tried it, lol.

IIRC, it would never work when the phone was connected to WiFi but would when connected to cell.

I checked and I had the WiFi indicator with the RW app (which is something that I’ve not been seeing much lately, the phone calls were weirdly mostly not using WiFi, but that’s a different story).

I’ll play with it some more and I’d be curious if other people can validate this.


Hi @robg.ev3gek,

Thanks for sharing your finding! I’ve moved your post into an existing topic about Google’s call screening, where some others have indeed validated that it’s working since an update to the Google app mid-August.
I’m glad to hear that it seems it wasn’t newly broken in Android 11!

I’ve got to be honest, I’ve turned off call screening. I’m unimpressed. Google does a good enough blocking without it, it catches as many of my business calls as it does spam, and people get really annoyed. This has turned out to be far more of a gimmick for my use case than anything useful.

1 Like

Working for me too on my Pixel 3. Awesome!

1 Like
Message an
Expert customer