Got a new Pixel 6, need to upgrade to 5.0 plan to activate?

I broke my ol’ trusty Moto Z (RIP) last week and got the Pixel 6 in the mail yesterday but can’t figure out how to activate it with Republic.

Sorry it seems like this has been a hot topic lately but I can’t really find a clear answer on how to upgrade my old plan and keep my number and everything.

1 Like

It’s an awkward time at Republic Wireless right now. They have temporarily suspended the process to move current customers to 5.0 plans. If you’re interested in an unofficial means to use your Pixel 6 with your current My Choice plan, you may wish to consult the post linked below:

3 Likes

Thank you! This workaround worked for me. Hope things get less awkward soon

5 Likes

This also worked for my new moto g pure phone. Thank you

2 Likes
  • This worked seamlessly for me moving a My Choice sim card from a moto e6 to a pixel 5a.

  • It almost worked moving a My Choice sim card from a moto e5play to a pixel 5a, but there’s some weird behavior. I’m not sure what’s different between this sim card and the other one from the e6 that worked, but with this sim card in the pixel 5a, outgoing calls show up as from the republic “hidden number” and not my actual number, and the phone can’t call other republic customers (just gets a busy signal). I’ll try a few more factory resets and updating the republic activations on the pixel5a before giving up and chocking it up to some unknowable difference in the sim that came in the e5play vs the e6 several years ago.

Have you checked the SIM type? If it’s My Choice CDMA SIM card it cannot successfully be provisioned in a new phone.

1 Like

Yeah, I made sure that it was a GSM sim card.
What ended up working was taking the sim card out, factory resetting the pixel5a, then putting the sim card back in and refreshing the republic activation again. And for some reason, it worked correctly after this. I think that why it didn’t initially work correctly was because the first time I attempted the republic activation, I typed the magic numbers into the dialer and then the republic app didn’t open and give me the permission prompts it’s supposed to – so the republic activation seemed to be stuck in a bogus state until factory resetting the phone and doing it again.
And then, of course, had to make sure turn off chat features to make messages come from the right number.
A bit of going around in circles, but got to a point where it’s working well enough until I can activate a new 5.0 plan and port my numbers to it.

2 Likes