Half of data magically used on first day of billing cycle

On the first day of my billing cycle, half of my data magically disappears. The Republic App shows it as “Other Data”. My phone does not indicate this excessive data use.

As a result, I get much less actual data than what I’m paying for.

I think that there is a serious bug in Republic’s data usage calculation. This is not the first time that this has happened.

It appears to be a bug that seems to be causing a delayed refresh of the data allotment for the new cycle. But your symptoms are slightly different than this one

What is “other data” category in RW app?

If it is the same issue, it should correct itself…if the issue persists longer, please submit a help ticket

https://help.republicwireless.com/hc/en-us/requests/new

Did you uninstall/reinstall the Republic app on this data? While it might be the bug that @amitl mentions, it is possible that there are other reasons.

I have submitted my second help ticket on this issue 2 days ago - it happened 2 months ago. No response yet.

Can you please let us know your ticket number?

A bug in an app should not limit data usage. This should be tracked and audited by Republic.

#1079553

I have requested Republic support to take a look at your ticket.

I have been assured that they are actively working on your ticket and you should have a response back from them shortly.

jonathanj.xzcjcv wrote:

I have submitted my second help ticket on this issue 2 days ago - it happened 2 months ago. No response yet.

To get the fastest possible service it is not recommended that you open multiple tickets on the same subject. Let me explain why. When this is done the tickets are merged. This puts the time stamp (the time that your ticket was opened) on the time of the new ticket. It is essentially like moving yourself to the back of the line when you open multiple tickets.

Message an
Expert customer