Having trouble making calls on an Ascend 5W


#1

@indras … Did you get an answer? I’m having the same issue. I have 0-1 cell bars at my home in the woods, but although phone says I’m connected to WiFi (I can surf web) I still can’t make calls. I’m sure it’s a setting I haven’t figured out.


#2

The OP did not give enough information or open a ticket so not even sure what the problem was, just one symptom.

I your case, the devil is in the details:

  • Tell us about your Internet connection. Is it Cable, Satelite, DSL, dial-up?
  • When you try to make a call what happens?
  • What model of phone do you have?
  • What does the Arc in the Notification Tray say?
  • Does the phone work away from your home WiFi? On Other WiFi?

What have you tried?

  • Have you restarted your router?
  • Have you turned off the ALG function in the router?
  • Have you read the Troubleshooting Section of this document?

#3

SeanR: FYI, my wife and I have the exact same phone and are accessing (or
trying to access, in my case) the same wifi signal at our home. She is able
to make calls via our home wifi, but I’m not. The message I get when trying
to make a call is “No cellular network available. Connect to Wi-Fi to make
calls.” And there’s an “OK” at the bottom of the message for me to exit out
of the message. The phone is an Ascend 5W, and when I view my internet
connection - under Arc in notification tray - (BTW, I’m able to surf the
web, so I know I’m connected) it states, "You’re connected to internet."
The wifi signal is fiber optic broadband DSL, and my phone is the only
device not completely working (making calls) via this signal, so I think I
must have an improper setting (operator error). I can receive a call at
home or away from home, and I can make a call while away from home (via
cell towers). However, I cannot receive a call while at home (no cell
signal available, only wifi). I’m not sure if I can make calls via wifi
away from home. We’ve only had these phones and this service about a week.

Larry


#4

Hi @runtherace,

I believe, you’ve run into a known bug with Huawei’s Ascend 5W that I’m able to duplicate at will merely by placing my Ascend in airplane mode (which disables both WiFi and cell radios) then turning WiFi back on. With the cell radio disabled I’ll get the same message about connecting to a WiFi network and I’m already connected to one.

It will take an operating system update from Huawei to correct this. Meanwhile, the workaround for making WiFi calls in the absence of a cellular signal is to use an alternative dialer rather than the Ascend’s native Phone app. I’ve used this one successfully:

The above said, I’m very curious your wife isn’t experiencing this issue considering she’s using the same phone. Might she already be using an alternative dialer or Phone app?


#5

@rolandh - When I go to the phone’s “updater” and check for updates, the
phone tells me “No updates” [available]. Phone is running version
H1623C435B131. I’ll download another dialer as a last resort, but if this
is a phone issue, I would think that Republic or Huawei should provide
support to assist in getting this 10-day old phone correctly configured. In
other words, it sounds like a warranty issue that can be easily fixed with
the proper coaching by experience technical personnel … via telephone if
necessary. If there’s one negative in dealing with Republic I would say the
lack of telephone support is the red flag that causes me the most concern.


#6

It is not a warranty issue since there is nothing wrong physically with the phone. An alternate dialer is a very simple option. The issue is that we are different than other carriers, as far as how calls work, and manufacturers expect that calls should always be made with a cell connection. For most carriers, that is the right answer, just not for us. The great thing with Android is that things like the dialer and other part of the phone software can be replaced if something is not working as you would like it to.


#7

I would agree, Huawei should offer a fix but has not yet done so. Republic cannot fix this as it requires an update to the Android operating system on the phone. Operating system updates are controlled by the manufacturer not Republic. There is no coaching or settings tweak that will resolve the issue.

From Huawei’s standpoint, I suppose the number of folks needing to make WiFi calls in the absence of a cell signal is relatively small. If this is a deal breaker for you, perhaps, a different phone would be a better choice? Republic does offer a 14- day money back guarantee.


#8

I tried the Reset Republic Credentials and the phone appears to be
operating normally when calling out using my home wifi. Thanks for your
assistance.


#9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.