Having trouble sending texts


#1

Moto X4, talk & text plan, no data, $15/month plan, CDMA (Sprint)

Upgraded from a Moto G3 to a Moto X4 a few weeks ago and have recently noticed a difference in my ability to send texts. I don’t travel much and at home on my wifi, I can send and receive texts just fine. Last week I traveled out of state and had some issues texting. I stopped at a McDonalds where I showed 4 bars of cell signal strength (no exclamation points or anything unusual). While inside, I also tried to connect to their wifi. The phone showed an excellent wifi signal but the Republic bar remained hollow. I was unable to connect to the internet via Chrome or any other app that used the wifi. I then tried to text my wife. Messaging app (Messages, stock messaging app that came installed on the phone) indicated that the message could not be sent and to tap to resend. I tried that many times but it wouldn’t send. At that point, I turned off the wireless to send the message via cell signal as I had 4 bars. Again, it wouldn’t send after numerous attempts. Gave up and went to my next destination about 30 miles away. At that point, I had a couple of bars cell signal and I tried numerous times to resend the text but again, it wouldn’t send. Gave up again and went to my last stop another 20 miles away in a small town. There I tapped the message to resend and it sent that text and a couple others that I’d tried to send earlier also. I also received a text. At that point I figured I was just having a bad communication day with my phone and quit trying to use it. Fast forward to today when I’m a few miles from my house where I’ve never had problems sending texts. I received a text from my wife but when I responded, I got the same message that it wasn’t sent, tap to resend. Tried that several times but nothing again. As I drove home I tried sending it several times but it would not send. All this time I have good cell signal. I finally arrived at home and connnected to my wifi at which point the message sent. My questions are: how do I troubleshoot my inability to send messages with my new phone in areas where my old phone worked fine (same CDMA service as old phone)? Why would the phone indicate that the internet/wireless connection was strong at McDonalds and I still had no access to the internet? Is there a setting that I’m missing somewhere on my phone that I need to change? Is the stock Messaging app an issue? Is it the phone or the new operating system? As an engineer I like to figure out and solve problems but this one has me stumped. It looks like I have all the ingredients to send a text i.e. good signal strength but nothing works. Its very frustrating! If there are any settings or data that I can post here that would help me figure this out, I’d be very grateful.


Issue Description


#2

On the X4 you will need to use the Messages by Google app or Republic Anywhere as your default messaging app.

On the My Choice Plans…you need to keep Cellular Data ON in your Data Usage settings even if you don’t have any cellular data on your plan.

The inability to use internet at public WiFi sounds like a separate issue.


#3

I think I am using the Messages by Google app. To keep cellular data on I checked to see that this slider is in the ‘on’ position: settings, network and internet, mobile network, mobile data = on and roaming = on. Is this correct or is there another setting that I should change? These were set to ‘on’ when I was having the problems. Thanks for your reply, appreciate your help.


#4

Yes, your cellular data settings appear to be correct.

Please make sure that you are using Messages by Google (This is the app that used to be called Messenger…then Android Messages…and most recently changed names to Messages by Google)
The stock Messaging App cannot be used on the My Choice plan.

Also, did you buy the X4 from RW or just the SIM card from RW…if it is the latter…then you would be on GSM coverage. See here for more info


#5

Thanks amitl for your help. I checked and I am using the Google messaging app ‘Messages’. I did not buy the X4 from Republic. It is a stock Motorola unit. I did initially set up the phone using a GSM SIM but then activated it and am currently using a CDMA SIM. You had me thinking that maybe I accidentally put in the wrong SIM but I double checked and its on CDMA per your directions above. Can you think of anything else it might be? Should I escalate my issue using a help ticket with Republic?


#6

Just tried to send a text from home. I turned off my wireless first. Text won’t send. I get the message “Text not sent. Tap to try again”. I then tried to call my wife’s phone next to me. Can’t call either. Something’s not right.


#7

When you turn off wifi, does the phone show a cellular signal at all? If yes, does it show letters near the cellular bars like “LTE” or “H” or “R”? Can you follow the directions above and tell us what it says after CDMA in the SIM type. I believe there should be something there like “csim” or “isim”?


#8

Yes, I have cell signal - 3 or 4 bars and no letters near the signal strength. After sim type (CDMA) it says ISIM. Hope this helps.


#9

Thanks… No letters indicates no data connection and this is usually the result of data being turned off in Android settings. Can you verify that it is on? On the X4 I think that’s under Settings – Data Usage. Check to make sure that’s turned on.


#10

Here’s what I show under Data usage: Data Saver = off, Mobile data slider = on. Seems like data is turned on.


#11

Digging around in the Republic App I see this warning (exclamation point) at the bottom of one of the pages: “No network connection. You do not have access to cellular networks. Try to find a Wifi network”. I’m showing 4 bars cell signal strength but on the far left of the notification bar I see a white triangle with an exclamation point symbol. Why would I show a cell signal and an error message like this?


#12

Where did the CDMA SIM card that you put in the phone come from?


#13

CDMA SIM came directly from Republic.


#14

Ok, specifically for this phone, right?

If so, let’s try these steps:

Please try the following steps to resolve this issue:

  1. Reboot the phone in an area that has a strong cell signal. (Some people have simply needed to step outside and reboot.) If this fixes it, stop.

  2. Please ensure the data is turned on in Android Settings. Settings > Data Usage > Cellular Data (some phones may say Mobile Data). If this fixes it, stop.

  3. Reset your Republic credentials by opening the dialer as if making a call and enter *#*#8647#*# (in on a Samsung phone hit the dial button). The screen should clear, when it does, restart the phone. If this fixes it, stop.

  4. This one is more complicated. This step will clear out any saved connections for Wi-Fi and Bluetooth that you may have already made. We’re going to reset the network settings.
    Go to Settings > More > Network settings reset
    Read the warning, tap “Reset settings.” You will be warned a second time. Tap “Reset settings” to confirm. The process will usually take 5-10 seconds and the cellular signal bars icon will go away for a moment. Once the cell signal bars icon returns, you should reboot the phone.


#15

I rebooted the phone and now it seems to be working. I turned off the wifi and I see a white Republic arch in the upper left. I was able to send a text to my wife’s phone over cell where before I was not able to do so. Does this mean that if I have this problem in the future that I need to reboot my phone again? I’ll be watching it closely (suspiciously :unamused:) for the next few days to see if its fixed. Not sure why it went from working to acting up like this. Thanks for you help


#16

You’re welcome!


#17

Oops, spoke too soon. I turned the wifi back off and tried to send a text. Back to the same problem again. In the republic app I show the message: “Calls over cell. No access to cell data, messages or voicemails. Check your network connection.” I also show a hollow Republic arch again. Something still is messed up. I’ll work through the rest of those steps.


#18

Worked through all 4 steps. None of them fixed the problem. As soon as I turn off the wireless, I can’t text. I show 4 cell bars and a hollow Republic arch. Only way I can send text is over wireless. Message in Republic app says: "Calls over cell. No access to cell data, messages or voicemails. Check your network connection.” Very strange because after the first reboot, it did work for a short while. Turning the wifi on and then off again made the problem come back.


#19

Some additional info that may or may not be relevant. The phone did a system software update last week. The Republic app version is: 3.23.0.65 Not sure if this info matters but it is something that changed just before I started having issues.


#20

There are lots of things that can possibly cause a phone to need rebooting. It’s a best practice to reboot at least once a week, if not 2 or 3 times each week. I doubt you’ll track a direct cause. If it was the Republic App you’d see lots of threads in the community about similar problems, so I don’t think that’s it.