Help ticket not working on RW?

What phone do you have? Moto G4+ and want to upgrade to G6

What plan are you on? unlimited with 1G

Does your plan include data, or just talk & text?


Issue Description

I spoke with a RW helper yesterday that helped me pick out a new phone because my G4+ is failing on a regular basis. He recommended I buy a G6 and then open a help ticket to request the appropriate SIM card set (CDMA SIM card) through a help ticket. I have submitted at least 4 help tickets, never get a reference number or e-mail and when I hit “Submit” it tells me to sign in, but I’m already signed in.

Hi @gvg1214 and welcome to the Community!

Are you, by chance trying to open that ticket from your phone? If so, updating its Republic app is supposed to fix the experience you describe.

Otherwise, you may open that ticket when signed into your Republic account here: https://account.republicwireless.com/account/tickets/.

Should that too fail, please direct email from the email address linked to your Republic account to help@republicwireless.com to get that ticket opened.

Thanks, I actually opened one from my phone and it worked the first time. I had signed in MANY times but it still was not working from my computer.

1 Like

Have you tried a different browser … or possibly re-booted your PC?
I just tried Chrome/Firefox/Edge and had no problem getting to the form

I get to the form, fill it out, hit submit and then nothing. And yes, I did try different browsers. Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer