Home wifi problems

What phone do you have?

What plan are you on?

Does your plan include data, or just talk & text?

I have moto x4
plan is my choice + 1gb
has all 3

Issue Description

We have Frontier for internet and we were having terrible problems staying connected to the web. Anyway their old netgear modems were discontinued so tech guy put in an Arris modem and now neither my wife or I can use some apps and cannot surf the web very well. My daughter has a Samsung 8 and she has no issues. our yahoo mail won’t open, amazon app won’t load, I tried going through google and no luck getting amazon to open. can’t open disney+ also. We turn off our wifi and not one issue, evert app loads but that is not possible to do unless we have unlimited data. TV, ps4, laptops all have no issue loading. Our internet is nice and fast but what do I do to make my phone and modem/router like each other. Has to be the new Arris modem/router!!!

Have you tried simply deleting and re-adding the Wi-Fi network on your phone:

Delete a Wi-Fi network from your phone

  1. Open your phone’s Settings app.
  2. Tap Network & internet And then|autox18 Wi-Fi .
  3. If needed, turn on Wi-Fi .
  4. At the bottom, tap Saved networks .
  5. In the list, tap the saved network that you want to delete.
  6. Tap Forget .

Add the Wi-Fi network again

  1. Open your phone’s Settings app.
  2. Tap Network & internet And then|autox18 Wi-Fi .
  3. At the end of the list, tap Add network .
  4. If needed, enter the network name (SSID) and other security details.
  5. Tap Save . If needed, enter a password.

What is the model of your Arris device, then we can check to see if there are any settings you may need to adjust


Yeah, I reset between on my phone which erased every saved WiFi and didn’t help.

Please check this post by @jben:

The only time I had something weird like that happen, I disabled IPV6 LAN routing to fix it. That’s been several years ago and was due to a bug in either the router or Android software. I can’t recall which.

1 Like

@guym Did you ever figure this out?

Yes, all fixed thank you very much

TIA … If you could share what fixed it?
Real world feedback is key to ensure validity &/or helpfulness of knowledge being shared with fellow members.

After numerous phone calls to our internet provider and 4 or 5 visits to our house by the technician, several attempts by him to fix the issue it including several new modems. Finally he went to the settings in the modem and changed the settings to DHCP and it worked off and on thru the day. The tech changed the settings at their hub coming to our house and it worked perfect. Haven’t had a single glitch since.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer