Horrible phone company

Horrible “Phone” Company.
Okay as long you do not talk on your phone. They have a terrible VOIP program. People can not hear you or you can not hear them. Lot’s of echo and other bugs. I tried to get help and they always blame it on my routers. What little I saved on service I spent on phones. I have been with Republic for five frustrating years. I will be leaving very soon.

2 Likes

Hi @kennym.77p8tf,

I’m very sorry to read that our service has not met your expectations. If you’d like the Community to help you troubleshoot your router, there are some people here who are very skilled at doing so.

If, however, you’re already set on leaving, we wish you all the best with your new carrier.

4 Likes

If you do want to engage the community, some basic information would help us try to help you

  • Which phone are you currently using?
  • Is it CDMA or GSM How to Tell If a Phone Is Active on GSM or CDMA – Republic Help
  • Who is your ISP and what router are you using? (Make/Model/Ver usually avail on a label on the back/bottom)
  • What is your Zip Code … NOT street, just the zip
  • Please elaborate on the problems you have, and what you have done recently with support that didn’t help so we don’t duplicate your efforts
3 Likes

There is not now or has there ever been a problem with the routers.

1 Like

Hi @kennym.77p8tf,

How many routers are you currently using at home?

There doesn’t have to be a “problem” with the routers - we’re not trying to suggest something is inherently wrong with them. Sometimes a setting can be configured to provide better reliability with our phones. If you’re not interested in exploring that possibility, we understand, I just wanted to make sure we weren’t overlooking an opportunity to help if one was available.

If your intent was simply to post a warning to others about our service, that’s fine, as well.

1 Like

I will start a new thread to troubleshoot, but I’m having the same voip issues. I always have to turn off Wi-Fi no matter where I am to make a phone call otherwise no one can hear me

2 Likes

I never get complaints when I’m on WiFi (Moto Z Play). But whenever I talk with a friend who’s also a RW customer (Moto E4) and he’s on WiFi, I have to turn my phone volume all the way up. If he switches to cell, I have to pull my phone away to protect my eardrum from the sudden volume increase. This is not a new phenomenon.

1 Like

Thank you! I will let the help team know. Including link to this thread for them as well. :wink:

1 Like

I’ve been with them since they began and I’m also leaving! ASAP!

1 Like

I had the same problem with my wife’s phone but it was an easy fix, just went to help and typed in the problem. Sorry it didn’t work for you

2 Likes

This post was flagged by the community and is temporarily hidden.

2 Likes

Your experience is quite different from mine. I’ve had several phones on Republic, currently a Pixel 3a and never had had such problems. Whether I’m at home on my wi-fi, at work with the company wi-fi or at stores and such with open or Spectrum wi-fi, I’ve had no volume/echo problems. So I’m really wondering what’s going on.

I have had 4 Moto phones including a Moto X, and two Moto X4’s. I bought the first Moto X4 new from Republic and sent it back because the diagnosed it with “microphone” problems. It was not the microphone, it was the VOPI program. They replaced it with a used Moto X4 with someone else’s customizations still on it. Currently have a Galaxy S10+ and have always had issues when on WIFI, anybody’s WIFI. Have to turn WIFI off, then all calls are clear as a bell!

Todd - any chance you could link to that thread here in the forum? I am intermittently having a similar issue, would love to give your “fix” a try… thanks, Bobbie

I’m going to try and find it, it was under help and I typed in people can’t hear me when I call. It gave me a code to type in on the phone keypad and then I restarted the phone and it was like magic. I will get back to you if I can find it again

Open phone app
Open Dial pad if not already open
Dial-. This code
Star, pound,star,pound,8647, pound, star,pound,star
No spaces
Allow any prompts that ask permission
If phone doesn’t restart automatically, wait one minute and restart it yourself
Do a test call
This has worked for me
Good luck

3 Likes

WOW TODD thank you for the fast reply!!! fingers crossed!

A trick to finding official doc from the Republic Help Team using the Spotlight search image is as follows:

  1. Select the Spotlight search (top right, to the left of your Icon)
  2. Select Help Articles image … The default Forum will return results from all the sources and make it harder to narrow down

Let me know. I hope it’s what you need

1 Like

I started with Republic when their public beta first went live. I’ve had the Moto X, X2, and X4 and I’ve never had an issue. It doesn’t mater if I’m on my home WiFi, WiFi at work, or some random public WiFi, I always get good speeds and clear calls.

1 Like
Message an
Expert customer